CONTENTS

AMT Camera Manual ........................................................................................................... 1
Everyday Procedures ........................................................................................................... 5
Measurements and Calibration .......................................................................................... 7
  Linear Measurements ....................................................................................................... 7
  Diffraction Measurements ............................................................................................... 8
  Calibration ....................................................................................................................... 10
  Image Zoom .................................................................................................................. 13
Calibration at High Magnifications ..................................................................................... 15
Measurement and Analysis Using ImageJ ........................................................................ 16
  Measuring Length Using ImageJ .................................................................................... 16
  Measuring Perimeter and Area Using ImageJ ................................................................. 17
  Measuring Angle Using ImageJ ..................................................................................... 17
  Particle Counting Using ImageJ .................................................................................... 18
  Measuring Intensity Using ImageJ .................................................................................. 20
Image Drift Measurement ................................................................................................ 21
Fast Fourier Transform Using ImageJ ................................................................................ 24
Viewing Serial Sections Using ImageJ Stacks .................................................................. 24
ImageJ Macros .................................................................................................................. 26
AMT Toolbar For ImageJ .................................................................................................... 27
Grayscale Manipulation .................................................................................................... 29
  The AutoGain Function .................................................................................................. 29
  White and Black Level Adjustments .............................................................................. 30
  Adjusting Gamma .......................................................................................................... 30
  Adjusting Sigma ............................................................................................................ 31
  Raising Contrast Using Thresholds .............................................................................. 32
Image Sharpening .............................................................................................................. 33
Image Processors ............................................................................................................... 34
Diffraction Imaging ........................................................................................................... 36
  Acquiring a Diffraction Image ....................................................................................... 36
  Diffraction Settings ....................................................................................................... 37
Saving Images and Cases ................................................................................................. 39
  Microscope Information Window .................................................................................. 39
  Saving via "File -> Save As" ......................................................................................... 41
  Changing the Default Image Saving Path ..................................................................... 41
Using Case Studies ............................................................................................................. 42
Archiving Cases ................................................................................................................ 44
ADVANCED TOPICS .......................................................................................................... 45
Image Properties and Corrections ................................................................. 45
  Bit Depth of Images .................................................................................. 45
Frame Averaging and Summation ............................................................... 46
Physically Based Flat Field Correction ...................................................... 48
Magnification Factor in Digital Imaging ..................................................... 49
Lattice Imaging with Bottom Mount Digital Camera .................................. 51
Camera Settings and Control ...................................................................... 52
Set/Save ....................................................................................................... 52
Recall ........................................................................................................... 54
Sample Region ............................................................................................ 55
Exposure Times and Gains .......................................................................... 55
Thresholds and Tails ................................................................................... 58
DISPLAY OPTIONS ....................................................................................... 60
Changing Image Display ............................................................................. 60
  Refresh Display ......................................................................................... 60
  Contrast Inversion .................................................................................... 61
  Center Cross .............................................................................................. 62
Show Saved Image And Caption ................................................................. 62
Undo Graphics .............................................................................................. 63
Draw Rectangular Grid ................................................................................ 63
Darken .......................................................................................................... 64
Show/Hide Options ..................................................................................... 64
  Show/Hide Control Panel .......................................................................... 65
  Show/Hide Large Mag Display ................................................................. 66
  Show/Hide Live Scale Bar ......................................................................... 66
  Other Show/Hide Options ......................................................................... 66
Continuous Mag Read .................................................................................. 66
Preferences -> Display Characteristics ....................................................... 67
  Speed Live Or Quality Live As Default ................................................... 68
Set Measurement Marker And Cursor ....................................................... 68
Select Font For On Image Text .................................................................... 69
Scale Bar Customization ............................................................................. 70
APPLICATIONS ........................................................................................... 71
AMT's Annotation Text Tool ........................................................................ 71
Montaging .................................................................................................... 72
  Collecting Montages ................................................................................ 72
Collection and Naming Conventions ........................................................ 75
Stitching Montages Using ImageJ or Fiji ..................................................... 77
Database ....................................................................................................... 81
The AMTHistory RTF File ........................................................................... 81
Meta-data In the Tiff Header ....................................................................... 85
Everyday Procedures

This section can be printed as a short, summary manual for visiting users.

1. **Camera Out for TEM setup.** For sidemounts, make sure the mirror is in the retracted position. For bottom/mid mounts, make sure the TEM viewing screen is down. Going to crossover at low mag, or using a diffraction beam for alignment could burn your camera phosphor if the camera is in.

2. **TEM Setup.** Find the beam, align the TEM and center the beam. Insert your sample and find a region of interest. Get your sample roughly into focus using the TEM viewing screen or the binoculars. Final focus will be done using the camera.

3. **Spread Beam.** Turn the condenser knob clockwise (from crossover), spreading the beam past the edges of the TEM viewing screen, until it appears somewhat dark.

4. **Camera on.** The power supply to the camera needs to be turned on, and the AMT computer booted up. Your lab manager may have already done this.

5. **Open AMT.** The AMT icon is in the start button menu and probably also on the desktop. Give the program a few seconds to open completely.

6. **Click for Live Image.** On the right side of the AMT interface, click the button “Click For Live Image”. This will start live imaging and if your system has auto-in it will also insert the camera. Otherwise you will see a dark live image until the next step.

7. **Camera In.** For sidemounts, flip the pneumatic switch on the bottom of the retractor to insert the mirror assembly. For bottom mounts use the button that raises the TEM viewing screen.

8. **Center the Histogram.** Once Live and inserted, check the light meter. That is the histogram on the right side of your display. If the red curve is in the left of the box, the beam intensity is too low. If it is on the right intensity is too high. Use the TEM condenser knob to move the red curve near the center of the box. If the brightness goes 'off scale', take the camera out to readjust.

9. **Changing Mag.** Lower Magnification Gently! Reducing the magnification in large steps can create a small, intense beam that can damage the phosphor. It is best to lower magnification one step at a time. Observe the Live Image and keep the beam spread using the condenser lens (TEM brightness control). If the TEM has Intensity Zoom, use it.

10. **Acquire a Background.** Everyday someone in the lab should refresh the background correction. For this either pull the sample rod out to the park position, or find a large hole in the sample, so the beam has no obstruction (not even Formvar). This should be at the KV you will be working at, somewhere near the anticipated mag and with whichever apertures you will be using for imaging. Cover the TEM viewing window to block ambient light. Click the “Corrections” item on the upper menu and choose “Acquire a Background”. The Background Control window will open, giving you the choice to “Proceed”or “Cancel”. If you haven’t already done it, center the Histogram. Place the histogram’s red curve in the center of the box using the Condenser 2 (brightness) knob. Then click “Proceed” and wait while backgrounds are collected for all four imaging modes. Then you can put your sample back in and go Live.

11. **Scan and Focus.** Using “Live Imaging”, navigate to your best region of interest, adjust the TEM mag and focus. “Focus” mode, the second radio button next to “Click for Live Image”, is a tool to aid focusing. It zooms in and enhances the resolution. Navigating black or white features out of the field of view will improve contrast. For other ways to improve contrast see the topic “Grayscale Manipulation”.


12. **Final Image.** When you have the image set up, hit "Click for Final Image" to collect it. It takes a few seconds to integrate.

13. **Save the Image.** After collecting a final image save it to your disk or network. If you are saving to a case which is already created, click the File Cabinet icon at the bottom of the left toolbar. In the "Camera Information" window make sure the mag and voltage are correct and click "Save With Caption". To create a new case click on the upper menu, "File -> Case Study". If not saving to a case, but directly to a folder, click on the upper menu, "File - Save As". Then navigate to your folder and type in a file name.

14. **Measurement.** For linear measurement have a final image displayed. Click the Ruler icon on the left toolbar to open the measurement window. Make sure the mag and voltage are correct and then click once on each side of a feature (do not drag). A list of your measurements appears in the measurement window, along with the calculated Mean and Standard Deviation.

15. **Camera Out.** When you are done imaging take the camera out for safety (for sidemount retract mirror, for bottom or mid mount lower TEM screen). Close the AMT software by clicking the upper right "X" or "File -> Exit".
Measurements and Calibration

These are the utilities for measuring features on image in the AMT Image Capture Engine. The basic ones are Linear (point to point) measurement and Diffraction pattern measurement. Calibration is similar in the two utilities.

Contents

Linear Measurement
Diffraction Measurement
Calibration
Saving Calibrations
Image Zoom
High Mag Calibration Issues
ImageJ Measurement and Analysis

Linear Measurements

1. To make a linear measurement, first have to collect a final image.

2. Next click on the ruler icon on the left tool bar (or on menu item Proc/Meas -> Point to Point Measurement). This will open the "Measurements" window.

3. Make sure that the voltage and mag displayed in the window are correct. If not, click on them to change the values.
Drag the window to the side, so it stays visible when you click on the image. Use ‘SetFormPosition’ to make the window open here from now on.

4. Make a length measurement by clicking once at each end of the desired feature to be measured. (Do not "drag"). A line connecting the two points will be drawn and a measurement label added. The measurement will also be entered into the list on the measurement form.

The style of the measurement maker can be changed from cross hairs to a target circle, and the cross hair size of the measurement marker can also be changed. These choices are found by clicking "File -> Preferences -> Display Characteristics -> Set measure marker and cursor”.

To remove measurements from the image, without removing them from the list, click “Proc/Meas -> Undo Graphics” on the menu over the image.

5. The measurement values are saved to a list in the Measurement window. The Mean and Standard deviation are calculated at the bottom of the window. The list, including Mean, Standard Deviation and Comments can be saved as a text file (click "File -> Save and Exit”).

Options for adding a comment, and for deleting a single measurement from the list and from the image, are in the “Edit” menu at the top of the Measurement window.

Measurement line thickness, measurement font boldness, size and style can be adjusted in Preferences.

Note: If you want to save the image, showing the measurements, do it BEFORE you close the Measurement window, as closing it may erase all measurements.

### Diffraction Measurements

1. Be sure to use the proper precautions for diffraction imaging (See "Diffraction Imaging").
2. After collecting a final image and going to Camera Out, click on the diffraction measurement button on the left tool bar. Alternately, click "Proc/Meas-Select Measurement Mode->Diffraction Measurement" from the upper menu.
3. Select either diffraction spot measurement or diffraction ring measurement from the form that is displayed.


The distance between diffraction spots is measured in the same way that point to point image distances are measured. Click once on each spot to measure the line between them. The measured distance will also be entered into the measurement form list and a line and label will be drawn on the image.
5. Diffraction Ring Measurement

Select ring measurement instead of spot measurement. Measure diffraction rings by clicking on three widely spaced points on the ring. A circle with the appropriate radius and center will be drawn and labeled. The radius of the ring is determined and entered into the measurement list.

6. To calibrate diffraction measurement use the same steps as those in linear measurement calibration (See "Measurement and Calibration--->Calibration"). The diffraction default calibration is kept in difCal.txt and the diffraction calibration Table Entries are kept in camConst.txt.

### Calibration

This page describes calibration for point to point measurement. Diffraction measurement calibration uses the same principles. Both types are password protected.

#### Default vs Table Entry

There are two kinds of calibrations for point to point measurement. "Default" or "Normal" calibration is a single calibration that is used for every measurement that does not have a special calibration. For many labs the default calibration is all that is needed. This single calibration is used for measurements at all mags and voltages, and it is extrapolated linearly (if the magnification readout of the scope doubles the calibration factor is doubled to compensate). A good choice of mag for doing the Default Calibration is about 10KX to 12KX. That avoids the calibration bending potential of the low mags and the error prone indefiniteness of the high mags.

The other type of calibration you can do is a Table Entry calibration. These special calibrations are specific to both the mag and the voltage, and so are more precise. They are automatically saved and called up whenever you do measurement at that mag and voltage. This allows you to keep inaccuracies in the scope's mag reports out of your measurements. The steps for doing table entries is basically the same as for doing a default calibration, except you choose Table Entry under Calibration to begin. AMT can store as many table entries as you like, up to one for each combination of mag and voltage that the scope has.

The Table Entries are kept in a file named "Mags4.txt" in the camera's configuration folder. You can bring that file up for review by clicking Calibration on the Measurements Window's upper menu, and then clicking Show Table of Calibrations Factors on the drop down list. The file has three columns: KV, Mag and Calibration Factor. The calibration factors may or may not be in scientific notation. There is one line for each of the table entries you have done. If any line has a calibration factor that's very different from the rest, you may want to check the calibration at that voltage and mag again. Doing the table entry process over at a voltage and mag will overwrite that line on the table, so you do not have to delete anything. The Default calibration is also stored in the file "Calib2.txt" in the configuration folder. That file gets overwritten when you redo default calibration.

#### Units of the Point to Point Measurement Calibration Factor

The calibration factors in Mags4.txt and Calib2.txt are in units of "pixels per nanometer at 1000 X". You
can easily check that the listed calibration factor is actually being saved with the image if you save an image taken with the screen mag at 1000X. During saving, in the *Microscope Information* window, choose "Pixel Size" under *Customize Magnification Display*. After saving, open the image in a processor, or, on the AMT upper menu click "Display->Show Saved Image and Caption". In the metadata displayed under the image find the line that starts with "Cal: ". That line gives the image's mag calibration as a length (in either microns or nanometers) per pixel. If the figure is in microns/pixel, multiply it by 1000 to get nm/pixel. Then take the reciprocal to get the pixels/nm of your image. Compare this number to the calibration factor which, if there is a table entry for this Mag and KV, is listed in *Mags4.txt*. If this Mag-KV combination does not have a table entry, then the calibration factor is listed in *Calib2.txt*. Both files are in C:\Program Files\Amt\AMTcommon\ConfigCam1 (ConfigCam2 for second AMT cameras).

For images taken at 1000X: pixels/nm = the listed calibration factor (within a ten thousandth)

Raising the mag by factor F will obviously display 1/F as much of your sample on the available pixels (nm/pixel ~ 1/F). So nm/pixel of an image is *inversely* proportional to the mag. Therefore, pixels/nm is proportional to mag.

\[
\frac{\text{pixels/nm (of your image)}}{\text{pixels/nm (of images taken at 1000X)}} = \frac{\text{Current Mag}}{1000X}
\]

SO:

\[
\text{pixels/nm (of your image)} \times \frac{1000X}{\text{Current Mag}} = \text{pixels/nm (at 1000X)} = \text{the definition of the calibration factor}
\]

OR:

\[
\frac{\text{pixels/nm (of your image)}}{\frac{\text{Current mag}}{1000X}} = \text{the listed calibration factor (within one ten thousandth)}
\]

So for instance if you take and save a picture at 3000X, and the underneath display shows Cal: = .004187 um/pix: pixels/nm (your image) = 1 / (Cal: * (1000nm/um)) = 1/ 4.187 * pixels/nm = .23883 pixels/nm

\[
.23883 \text{ pixels/nm} / 3 = .079611 \quad \text{which is the calibration factor.}
\]

It may be displayed in *Mags4* or *Calib2* as "7.9611E-2" which is scientific notation.

**Calibration Stability**

The phosphor placement, lens spacing and phosphor to CCD chip distance are all static. Distances and dimensions are fixed so this calibration also stays fixed over time. Uncertainties in the magnetic fields generated by the TEM lenses (magnetic hysteresis), uncertainties in positioning the sample at eucentric height, and uncertainty in determining the boundaries of a calibration object (Grating replicas do not have sharp features.) are the precision limiting factors in overall magnification calibration. A periodic check of calibration is still a good idea, to check for possible drift in microscope electronics.

**Calibration Steps**

1. The first step in calibrating your measurements is to collect a final image of something you know the size of, like a calibration grid. Grids like the one used in this example are available at http://www.2spi.com/catalog/standards/othertem10.shtml. Calibrating at high mag requires a different kind of standard (see the page "High Mag Calibration Issues").
2. Next take some measurements. Click on the ruler icon on the left toolbar to open the measurement window. Make sure that the correct Mag and Voltage are listed. Correct if necessary. If using a repetitive grid measure a number of squares (10 if possible) instead of one, to reduce error. Measure in both directions. Delete the measurements that are obviously wrong (Edit -> Delete).
3. If calibrating diffraction measurement, use spots which are a known distance apart, or rings of known size. Make sure the Cam Length and Voltage are correct.

4. When you've got your target measurements click "Calibration" on the upper menu. Besides options for Default and Table Entry calibrations, there is an option to display the table of calibrations for specific Mag-KV combinations. There's also a reset option, for deleting all your table entries and starting over. Resetting is not necessary for redoing a table entry or the default calibration. New values will overwrite the old ones.
5. After you choose the type of calibration and enter the password the "Magnification Calibration" window will appear (or, for diffraction, the "Diffraction Calibration" Window).

![Magnification Calibration Window](image)

6. At the top of the Calibration window you choose whether to use the last (or selected) measurement or the Mean of the measurements as a standard. If you feel that one of your measurements is very representative use that as a standard. If you're measurements give kind of a spread, say, over different directions, use the Average as a standard. If your measurements are different in the X and Y directions, averaging them will split the difference. Have the same number of measurements in each direction.

7. Enter the length of the known objects measured (Correct Distance). The window contains an optional use calculator to help calculate the distance of repeating patterns. The calculator's Repeats per mm setting defaults to 2160 because that what most calibration grids have.

8. Clicking "Proceed with Calibration" finishes that calibration and adds the factor to the appropriate file(s).

9. Use the same steps for calibration of diffraction measurement (after clicking on the "DifOff" icon on the left toolbar). The diffraction default calibration is kept in difCal.txt and the diffraction calibration Table Entries are kept in camConst.txt.

**Image Zoom**

*Image Zoom* increases the mag of a final image for viewing details. The "Zoom" icon is near the bottom of the left toolbar. To use it one first needs a final image, either a new one or a reopened one.

At the bottom of the Zoom icon it displays the current zoom factor. "Off = 1" is the unzoomed image.

Use the Zoom function by clicking once on the Zoom icon and then clicking on the image. The point where you click will become the center of the zoomed image. Zooming always increases displayed mag by a factor of 2. After you've zoomed in, right clicking the image zooms out (unzooms) by one step.
Below is a final image of a biological specimen. The red arrow points to an area of detail that we want to examine more closely.

After we click once on the Zoom icon and once at the tip of the red arrow the picture below is displayed. The sample is displayed twice as large, and the Zoom icon button says "2X". The point where we clicked is now in the center of the image. If we had clicked the wrong place, we could undo our mistake by right clicking, to unzoom, and then zooming again.

Here we've zoomed in a second time, so the displayed mag is 4 times the original.

The Zoom function does not allow measurement on zoomed in images.
Calibration at High Magnifications

To calibrate in the higher magnification ranges it is a good idea to use a material standard. Available materials are:

1. Catalase, which has two fairly large lattice spacings 87.5 A and 68.5 A.
2. For higher mags Crocodilite has 9A and 4.5A.
3. Copper Phthalocyanine is another material that is sometimes used but it is beam sensitive.

Lattice images of gold or graphitized carbon can also be used. The carbon layers tend to bend and finding any place with more than a few planes visible is not easy. There are also (very expensive) superlattice material that is made especially for TEM calibration. Most suppliers have these materials available. You can check them out (for example) at: SPI's website: http://www.2spi.com

Crocodilite is SPI catalog # 02908 – AB
Catalase is SPI catalog # 02905 – AB
The MagiCal superlattice standard is SPI catalog # 02218 – AB.
Measurement and Analysis Using ImageJ

ImageJ is an image processing application written by Wayne Rasband. It is a work of the United States Government, is in the public domain and is open source. It is available from the National Institutes of Health (NIH Web Site). All modifications, source code, applications and additions to this program by AMT are also freely available from AMT.

This is a supplement to the existing documentation for ImageJ. Its main purpose is to highlight and introduce operations typically used with CCD images obtained by transmission electron microscopy. This orientation also describes customizations made by AMT for TEM imaging.

AMT Automatically Embeds Scaling Information

ImageJ can easily be set up to do measurements on AMT images on any Windows computer. Spatial calibration information is incorporated into the tiff file header when AMT’s Capture Engine saves a file. When ImageJ is accompanied by the AMT Toolbar, it will read the calibration parameters for an image when it opens an AMT tiff file. If the calibration information is not present, an alerted box will remind you to manually calibrate the image (Use ImageJ’s menu Analyze/Set Scale to do this).

Calibration information may be lost if you open an image in another image processor and then overwrite the original image.

Contents
- Length Measurement
- Perimeter and Area Measurement
- Angle Measurement
- Particle Counting
- Intensity Measurement
- Image Drift Measurement
- FFT
- Viewing Serial Images
- ImageJ macros
- AMT Toolbar for ImageJ

Measuring Length Using ImageJ

Open a Tiff Image in ImageJ and select the line tool from the ImageJ toolbar. The last image saved by the AMT Capture Engine may be opened by pressing the F5 key. Select the line tool from the ImageJ tool bar.

Position the cursor at one end of the object to be measured. Click and drag to the other end of the object. Type F1 to enter the length of the line drawn into the measurement list. A line between the start and end points and a label will also be drawn on the image. Repeat the process for other objects that you wish to measure. For difficult or small objects you can use the zoom tool and then make measurements. More accurate measurements, of course, are obtained by collecting a higher
Measuring Perimeter and Area Using ImageJ

Distance along an irregular path or a perimeter can also be measured by selecting the Segmented Line Selection or the Freehand Line Selection tools in the ImageJ toolbar. You will need to select the measurement (area, perimeter, etc.) to be displayed in the menu Analyze\Set Measurements Menu item.

![Set Measurements](image)

After you have drawn the curve type $\text{ctrl-m}$. The measurements selected will be displayed in a Results box.

![Results](image)

Units are the length units of the image. In this case nm and $\text{nm}^2$.

Measuring Angle Using ImageJ

Angles can be measured by selecting the angle measurement tool.

![Angle Measurement](image)

On an open image double click on the first point, single clicking on the vertex, and click once more at the terminus of the final ray. After you have drawn the angle type $\text{ctrl-m}$.
The angle measurement is displayed in a Results Box.

**Particle Counting Using ImageJ**

ImageJ can automatically count the particles in a whole image or a selected part of the image. You determine what gets counted as a particle by thresholding the image’s grayscale values to suppress background features and accentuate the desired features, and also by setting limits to the size of a particle. It’s also possible to require a set degree of “roundness” to be a particle. The steps below are a tutorial for particle measuring. For more information on this operation see the website: [http://rsb.info.nih.gov/ij/docs/](http://rsb.info.nih.gov/ij/docs/).

1. Open ImageJ, either by clicking on the ImageJ icon on the left side of AMT’s display, or by clicking on ImageJ in “Start -> Programs”.

2. Open a saved image in ImageJ. For this tutorial, open “C:\AMTCommon\AMTSampleImages\Imgld1cal.tif”.

3. Use ImageJ’s crop tool to separate an AMT image from caption area. One click with the tool will effect the separation. After the separation reselect the square tool, and close the caption window.

4. Next we separate the particles from rest of the image by setting the black/white thresholds around a narrow set of gray values. Make sure the image to be measured is selected (clicked). On the ImageJ menu click “Image -> Adjust -> Threshold”. Under the histogram that comes up you can change the thresholds by moving the bars or click “Set” to type values into a window. A lower value of 17 and an upper value of 70 worked well for our immunoGold particles at 10KX. You may want to experiment with these settings, but when you find values that work, be consistent will all your samples. After setting the thresholds click “Apply”, and click all three boxes in the dialog box setting threshold pixels to black and other pixels to white. This makes the image “binary” having all black particles on a white background.
5. Tiff files saved from the AMT program have tags that will set the measurement scale for ImageJ. If other kinds of images are used you’ll need to set the scale, using a feature of known size, in “Analyze – Set Scale”.

6. In “Analyze – Set Measurements” select which measurements you’d like saved for each particle, and the number of decimal places to be displayed in the results. Counting small particles in a 10KX image requires six decimal places. For other mags or for large particles you may have to experiment with decimal places. Grayscale measurements will not be terribly meaningful, since we’ve made the image binary (each pixel black or white) when we set thresholds.
7. The “Result” window (upper right below) displays a number and the selected measurements for each particle. The “Summary” window gives the Count number, Average Size, Total area of the particles and the Area Fraction covered by the particles. The “Particle Size Distribution” window show a histogram with the particles grouped into bins according to their area. The statistical values displayed below are for particle area, not grayscale values.

For more information about analysis with ImageJ see the website http://rsb.info.nih.gov/ij/docs/.

**Measuring Intensity Using ImageJ**

Intensity Measurement Cautionary Note

Measurement of image intensities and gray scales can also be done. However, it is important here to remember that the Capture Engine normally applies a contrast enhancement to images as they are acquired and displayed. This improves the appearance but modifies grayscale information. If quantitative measures are to be applied to image intensities, the contrast enhancement of the Capture Engine should be turned off and images should be saved as 16-bit tiff files.

To measure the gray scale value at a point simply position the cursor at a point of interest and the gray scale intensity is displayed in the status bar just below the ImageJ tools. Alternatively, the Point Selection tool can be used.

Select a pixel with the tool and then type ctrl-M to display the intensity in the Results window. The values in the Results window can be saved.

Line profiles can be generated by drawing a line through the features and then selecting **Analyze\Plot Profile** or pressing the ctrl-K key. To improve the statistics of the plot one can select a rectangle in which case a column average profile is generated.
Image Math

Extraction of interesting features from a complex image can be a challenging aspect of image analysis. It is very useful to be able to perform simple mathematical functions on whole images and between two images. Once a sequence of operations is found to be useful a macro can be created to automate that sequence. Embedded in the particle counting macro discussed below, for example, is an algorithm to extract small dense particles from a complex image that includes both tissue and gold particles. This algorithm relies on some simple math. The image is first blurred and then a portion of it is subtracted from the original image. This tends to enhance small particles and suppress the background. The Image Calculator in the Process menu permits one to add, subtract, multiply, divide, and apply several other operators to pairs of images.

Image Drift Measurement

Installation

Use the ImageJ installer ImageJ138g_V306_20070404 or later installer. Run Setup.exe and accept defaults. The installer will install the required startup macro, and the TurboReg plugin that it calls.

Setup

The input tiff images should be placed in a single folder and have file names that end in _xxxx. Where xxxx is the time of acquisition. E.G. test_0000.tif was acquired at time = 0000. The time units are seconds.

All images should be taken at the same magnification and written by AMT's Capture Engine which embeds scaling information into the tiff image header. This information is used by the macro to calculate a real drift rate.

For testing purposes the installer placed a canned set of test images in the folder C:\AmtCommon\AmtSampleImages\CannedImages. These images will be used to demonstrate use of the drift measurement macro/plugin.
Running the Macro

The macro is activated by selecting the menu item `Plugins\Macros\AMT Drift Measurement` or equivalently by selecting the F3 key. This will display an introductory message with acknowledgements to the TurboReg plugin authors and instructions.

Click OK.

Use the "Choose Directory" dialog that is displayed next to locate the images whose drift you wish to measure.

The macro will display the first image and request a choice of length units.

Select the unit and click OK.

The macro will now sequentially open the images measure the drift relative to the previous image and enter the results into a Log table.
These results may be saved to a file by selecting "File/Save As" on the Log form if desired.
Fast Fourier Transform Using *ImageJ*

**Background**

The Fourier transform expresses an image in terms of the spatial frequencies in the image. A sharply focused image will be rich in high spatial frequencies. Large uniform areas are represented by low frequencies. Images with repeated features will have Fourier Transforms with repeated strong peaks. This can be used to select various parts of an image and can be very useful in removing artifacts, or improving image sharpness. *ImageJ* has a built in FFT and in addition there are several plugins posted on the NIH web site ([NIH Web Site Plugins](http://nih-web-site-plugins)) that implement their own specialized versions of the algorithm. See for example:

- Band pass filter
- Arbitrary size 2D and 3D transforms

There are also plugins that rely on the FFT as an integral part of the algorithm they implement. These include convolution, filtering, and deconvolution plugins - these algorithms are more efficient when performed in fourier space. Many of these plugins are provided with references to the literature.

**Doing the FFT**

Doing the FFT of an image is straightforward. open an image. Select the region of interest on an open image and then in menu **Process menu select FFT**. Since the FFT is usually implemented for regions that are even powers of 2, the nearest power of two sized region is automatically used in the FFT.

---

**Viewing Serial Sections Using ImageJ Stacks**

A sequence of images obtained from a serially sectioned sample can be used to create an ImageJ "Stack". A "Stack" is a way to animate and visualize a sequence of images and ImageJ has routines that use stacks to display 3 dimensional information. In addition to the intrinsic capabilities of ImageJ plugins have been written to augment the 3D viewing capabilities of ImageJ.

The first step is to obtain a sequence of serial images through an object of interest. In a real experiment this is done by sectioning the object and then carefully collecting the sections in the order that they were...
sectioned. To experiment with and become familiar with the ImageJ stacks we include a simple macro to generate synthetic images which can be assembled into a stack. The macro is “AmtDrawStack.txt” and is located in the C:\Program Files\ImageJ\macros folder.

1. The “AmtDrawStack” macro is a very simple macro that creates 50 images (01.jpg to 50.jpg) and stores them in the folder “C:\images\ImageJ\SampleStack.” You must create the folder C:\images\ImageJ\SampleStack before running the macro. Install the macro “AmtDrawStack.txt” by copying it into the folder: C:\Program Files\ImageJ\macros. Another useful macro for this exercise is AmtOpenSet.txt. This macro opens the 50 images generated by AmtDrawStack. Install the macro AmtOpenSet.txt by copying it into the folder: C:\Program Files\ImageJ\macros.


3. Install the “Volume_Viewer.jar” file by copying it into the C:\Program Files\ImageJ\plugins folder.

4. Obtain serial images through an object of interest. To experiment with the plugin using synthetic (generated) images run “AmtDrawStack.txt” by going to the ImageJ menu Plugins\macros\Run and then locating the macro in the folder C:\Program Files\ImageJ\macros. The images generated by this macro will be found in C:\images\SampleStack.

5. Open the images in order. Use the macro or you can open the images directly from ImageJ using the keyboard shortcut Ctrl-O and then double click the image icon. These shortcuts may be helpful since Image J does not have a group open command.

6. Create a Stack from the images. Go to the menu “Image\Stacks\Convert Images to Stack.”

7. You can animate the stack by going to the menu: Image\Stacks\Start Animation. This will cycle through the images. You can also save the stack by using the File\Save or the File\SaveAs menu. You must save the stack in the tiff format.

8. Once you have a stack go to the Plugins\VolumeViewer menu item. This plug in will allow you to observe the images from different orientations. ImageJ also has some viewing capabilities in addition to the simple animation in the Z dimension (See the other options in Image\Stacks). In particular, “Image\Stacks\3D Project” allows you to create an animation of the images rotating. Pixels of certain values can be set transparent so that embedded objects (like the cone) can be visualized. Try “Image\Stacks\3D Project” with the following parameters:

![3D Projection](image)

The Upper and Lower Transparency Bounds allow one to specify pixel densities that are ignored. Since the cylinder and cone have different gray scale values setting the upper bound between the two values (e.g. 170) makes it possible to visualize only one of the structures.
ImageJ Macros

Macros are sequences of commands, which can be executed as a single operation. A few examples of AMT generated macros have been mentioned and used above. Particle counting, drift measurement, and measurement and labeling make use of both intrinsic ImageJ operations, plugins (to be discussed below) and macros. An existing macro can be run by selecting the menu Plugins\Macros\Run and then navigating to the location of the macro. Macros are usually kept in:

C:\Program Files\ImageJ\macros

Macros can also be installed as a menu item or assigned a keyboard shortcut.

ImageJ has over ninety standard macros that are supplied as part of the initial installation. These macros range from functions that alter every image pixel, to measurement of image parameters and dimensions to drawing tools. More information is available on the NIH web site under “ImageJ Plugins”.

The macro StartupMacros.txt is a special macro that runs when ImageJ is launched. It can be used to define shortcuts to macros and place macros in menus and tools. AMT has set this up to install a useful sample set of macros as menu items and shortcuts. It can be modified by the user as desired.

The AMT shortcuts are:

<table>
<thead>
<tr>
<th>AMT Shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shortcut</td>
</tr>
<tr>
<td>F1</td>
</tr>
<tr>
<td>F2</td>
</tr>
<tr>
<td>F3</td>
</tr>
<tr>
<td>F5</td>
</tr>
</tbody>
</table>

In addition to these there are several ImageJ standard shortcuts. See http://rsb.info.nih.gov/ij/docs/shortcuts.html

ImageJ Recording Macros

The easiest way to create a macro is to open the command recorder under the menu item Plugins/Macros/Record Then record a series of commands, and click Create. In record mode, each menu command you use generates a call to ImageJ’s run() method. This method has one or two string arguments. The first is the command name. The optional second argument contains dialog box parameters.

ImageJ Plugins

Plugins are another form of extension available to the user of ImageJ. Plugins are very powerful and execute much faster than macros. More information as well as over 100 plugins are available on the ImageJ web site:

http://rsb.info.nih.gov/ij/docs/menus/plugins.htm

ImageJ has a large body of users and many plugins and macros have been created and contributed to
AMT Tools and Macros

AMT has generated some tools and macros that you may find useful. Macros in the C:\Program Files\ImageJ\macros folder whose name starts with AMT may be useful or provide useful examples for functions you may wish to build into your own macros. Macros are written as text files and these files begin with comments that document their function.

The AMT Crop function

strips away the AMT image label so that image processing can be done on just the image.

********************************************************************************

AMT Toolbar For ImageJ

When the AMT Toolbar for ImageJ is installed it will open when ImageJ opens. It contains a number of shortcuts which are designed to make working with ImageJ faster and easier. Call AMT to get the installer for the toolbar. Ask for the "ImageJ Enhancement Kit".

Contents

AMT Toolbar Installation
Toolbar Layout

********************************************************************************

AMT Toolbar Installation

AMT's ImageJ Customization Kit includes the installer "AMTImageJSupport.exe" and a .pdf file "AMT Img Processing.pdf" with info about the functions which the Toolbar calls.

If your computer already has ImageJ v1.47p or later, bundled with java, it should work with the Toolbar add on. If you have an earlier version on ImageJ, uninstall it and download the latest version, bundled with Java, from http://rsbweb.nih.gov/ij/download.html or google for “Download ImageJ". Once the proper version of ImageJ is installed run "AMTImageJSupport.exe". The AMT Toolbar should open whenever ImageJ opens. Both should open from the shortcut to ImageJ on you AMT Image Capture Engine display. If the shortcut does not work, you may have to edit the ImageJ line in the file "Links.txt" in your camera's configuration folder.
Toolbar Layout

Open Image - Same as "File -> Open" on the ImageJ toolbar.
Open Last Saved AMT Image - Opens the last image that was saved in the AMT Image Capture program
Save - Resaves an image.
Save as tiff - Saves the image, as a .tif, in whatever folder you navigate to.
Measure & Draw - Click this shortcut, then draw a line by dragging the cursor, and the line’s length is given.
Add Scale Bar - Click this shortcut, click "OK", and click on the image to add a scalebar. A form will appear where you can change parameters.
Annotation - Click the desired location on the image first, then click this shortcut, and then type in your test for placement.
AMT Crop - Separates an AMT image from its caption bar, each of which can then be saved with a new name.
Drift Measurement - This shortcut calls a comparison macro which uses ImageJ's "Turboreg" plugin. Images for comparison have to be renamed as described in the opening window.
Image stitching - This shortcut calls ImageJ's stitching plugin. After clicking the shortcut navigate to the folder holding you AMT montage. See "Stitching with ImageJ or Fiji"
Grayscale Manipulation

TEM images usually require some grayscale adjustment. Traditionally most user adjustments are done after the image has been saved, in a program like PhotoImpact. But there are a few utilities that work very well (even 'best') in AMT, and can give a nice image in the shortest time. The AutoGain function in the AMT program is constantly adjusting grayscales in your image, in order to put the camera's contrast range to best use in displaying your sample. There are things you can do to effect the way that adjustment is made, and adapt it for special sample characteristics.

Contents

The Autogain Function
White and Black Level Adjustments
Gamma Adjustment
Sigma Adjustment
Raising Contrast Using Thresholds
Image Sharpening
Image Processors

The Autogain Function

AutoGain

In the histogram display shown here the area between the two vertical green lines represents the camera's output grayscale range, 0 to 255. The sample's grayscale range (the camera's input) is represented by the entire width of the display window. As you can see, the camera's output capacity is restricted to, or focused on, those sample grayscales which are occupied by your sample. This ensures that the available image contrast is put to best use displaying features, not analyzing the blacks and the whites. The camera actually does see all the sample's grayscales (the entire window), but pixels outside the green lines are seen as pure black or white, thus taking a minimum of the camera's analytical capacity.

Thresholds and Tails

The Thresholds and Tails control where the green lines go (see "Camera Settings and Control Window"). If the thresholds are set to zero, the green lines stay at the edges of the display window, so there is no enhancement of contrast in the occupied pixels. Higher thresholds move the green lines closer together, enhancing contrast. The default for thresholds is 10 but some microscopists prefer thresholds of 50 or more. The tails move the green lines away from the center, by a percentage of the distance between them. Their main function is to control "blotchiness" when samples have a lot of extremely dark or light features.
White and Black Level Adjustments

A gridbar or other extreme black or white items often give your histogram extra sharp peaks on the left or right. This forces the system to divert the dynamic range from the main collection of pixels and into the far black or white regions, making the main features look "washed out" (See "The Autogain Function"). Manual "Black" and "White" level adjustments are often the easiest way to correct the contrast. By manually moving the green lines with the sliders you can keep those extremes from hogging the contrast. Essentially you're telling the camera "don't analyze what shades of black that gridbar has, just call it "black, and analyze my sample instead".

In order to change levels in live images you first have to click the AutoGain's "Off" button. You can leave it off while you collect a final image. Be sure to turn it back on before you change magnification or illumination.

Adjusting Gamma

Adjustments to Gamma and Sigma can be done in a live or a final image, and does not require that the AutoGain be turned off. Adjustments done in live imaging will stay in place for the session.

Changing the Gamma changes the shape of the gain distribution line (the diagonal green line between the vertical green lines). Adjust by sliding the "Gamma" button right or left while viewing either a Live or Final image. The same button is used for both the "Gamma" and "Sigma" functions. If it currently says Sigma, click it and it will go to Gamma. Clicking the "Neutralize Gray Map" button sets both Gamma and Sigma back to their default (neutral) value, which is one.

The histograms (red curves) in the following two examples have two peaks. The larger one represents a concentration of pixels in the image's dark areas and the smaller one represents pixels in lighter areas. In the first example Gamma has been raised by sliding the "Gamma" button to the right. The gain line is now an up opening arch.

This makes the slope of the gain line small in the part of the grayscale occupied by the large (dark) peak and large where the image's lighter regions have their peak.

Gain line slope represents contrast. Therefore, a raised Gamma means more of the available contrast is assigned to the lighter regions. This makes it easy to see the difference between light and very light features, but difficult to see the difference between black and almost black ones. On the right side of the raised Gamma image below, one can easily make out the differences in the thickness of the substrate. On the darker, left side of the image there's not much contrast available for distinguishing features. Dark and very dark are compressed together into a dark blob.

Gamma greater than one - light regions more contrasted. Histogram's gain line curves up.
In the second example the Gamma has been lowered. Now the gain line is a downward opening arch. Its slope, and the fraction of the available contrast used, is much larger for the dark area peak than for the light area peak. This means that the differences displayed between light and very light will be diminished, and features in the light area are less distinguishable. Difference in the dark areas however are much more distinguishable. One can see what might be deposits in the dark tissue.

Gamma lower than one - dark areas more contrasted. Histogram's gain line curved down.

Changes made to Gamma in live imaging are preserved in a recorded image even though the displayed gain line will straighten out. The adjusted Gamma will still be in place when you go back to live imaging.

**Adjusting Sigma**

If you click the "Gamma" button it becomes the "Sigma" button, and the slider bar now adjusts Sigma. Like Gamma, Sigma changes that shape of the normally diagonal gain line, reapportioning the way contrast is distributed over the grayscales. Raising Sigma makes the gain line an "S", so there is less slope on the black and white ends and higher slope over the middle grayscales.
This puts more of the available contrast in the center of gravity of your histogram. The extra contrast in the middle is gained by sacrificing a little contrast on the dark and light extremes. In biology the middle gray scales are often where most of your important edges are, transitions from middle gray+ to middle gray-. So raising Sigma will often give a prettier picture, especially at low mag, and especially for users who print out their pictures.

Sigma = 1    Sigma = 2

Note: If the features you're interested in are light features surrounded by a light background, or dark features surrounded by a dark background, this is not the best adjusting tool (See "Gamma Adjustments").

Clicking "Neutralize Gray Map" returns Sigma to its default of 1.

Raising Contrast Using Thresholds

Black and White Thresholds

One way to do a general bump up in contrast is to raise the Black Threshold and the White Threshold temporarily. The Thresholds are both set up for a default value of 10, but you can experiment with higher values, even up to 10,000. The Thresholds tell the Autogain how hard to squeeze the camera's contrast around the contrast changes actually displayed by your sample. Higher Thresholds mean the green lines in the histogram will be closer together. This will force a few more pixels out from the green lines to the right and the left, where they will be displayed as pure white or pure black. It also increases the grayscale spread left for the remaining pixels. For a more theoretical discussion see the topic "Settings -> Camera Settings and Control Window -> Thresholds and Tails ".

At the lower right of your AMT display click the "Set/Save" button to open the Camera Control window. The Thresholds settings is at the lower right of that window. After changing the values using the dropdown selection or a typed in value, click "Apply For Now Only" so you do not change the setting permanently. Then go back to "Live Image". The Autogain is left on, so this adjustment will follow your light changes as you change mags or brightness.
After changing the Threshold values, click "Apply For Now Only".

**Image Sharpening**

**Compare Images**
Sharpening can make a picture look prettier. It is most likely to be useful at lower mag, and with a sample that had some difficulty in preparation. It does involve a tradeoff. Sharpening can make a picture look gaudy and grainy and can interfere with the finest details. If your finest details are coming through O.K., you probably don't need sharpening. Deciding that requires experimentation, comparing image next to each other in a processor.

Not Sharpened    Sharpening Level 1

AMT Sharpening
. There are two ways to sharpen in AMT: "Enhance current Image Only" (on a collected final image) and "Auto-Sharpen" (on all final images). To enhance the current final image, click on "Proc/Meas" on the top menu and choose the Current Image enhancement option.
To set the **Auto-Sharpen** level click "Set/Save" to open the **Camera Settings Control Window**.

With either way of sharpening you can choose Level 1 to 3. Level 3 is the most extreme sharpening. ("3x3 Median Filter" is a specialized function. It would be bad for normal imaging). Most sharpening jobs only require Level 1.

The severity of the sharpening is set in the camera’s configuration folder in the file "Sharpen.txt". The top number sets the level for Sharpen 1, the bottom number for Sharpen 3. Higher numbers in this file mean softer sharpening. In some labs those three numbers are changed to 180, 125 and 90, so that Sharpen 1 is more like Sharpen 1/2 etc.

### Image Processors

Photoshop, PhotoImpact and ImageJ are examples of **image processors**. They have a variety of tools for manipulating grayscales and other image subtleties, sharpening, measuring, counting and analyzing. They also can be used to convert images into .jpeg images and for sending images to a printer. The two Image features you’ll adjust most are Contrast and Brightness. In order to print out nicely, images often need their contrast increased until they almost look gaudy on the computer screen. When you adjust images in a processor, you probably want to save them with a different name, so you keep the originals.

Other basic processor adjustments include Levels, Gamma and Curves, all of which are used to divide up the available contrast, so it gets used most efficiently to display the important features in your image. See the PhotoImpact manual for directions on using its features. ImageJ a subchapter here and a lot of free documentation online. It has subroutines for counting particles, measuring area and doing Fourier analysis. See “In Depth Measurement and analysis using ImageJ”.

The AMT Capture Engine display typically has shortcuts to one or more image processors on it. The top two icons on the left toolbar of this AMT display are shortcuts for opening **PhotoImpact** and **ImageJ**.
Diffraction Imaging

This chapter describes procedures and precautions for acquiring diffraction images.

Contents
- Acquiring A Diffraction Image
- Diffraction Settings

Acquiring a Diffraction Image

**Precautions:** Certain precautions are necessary for taking diffraction images. Diffraction produces bright concentrated spots or rings which can damage the phosphor of your camera. Lower illumination, shorter exposures and a central beam blocker are preferred. Please follow the following four precautions:

1. Use a “central beam blocker” if available. Many electron microscopes have one built in. It is sometimes called a ‘pointer’. The idea is to block the bright central spot that usually dominates a diffraction image. Get the device centered so it blunts most of the brightness of the central spot before imaging, with the camera out, using the TEM viewing screen.
2. Find and focus diffraction patterns using the TEM viewing screen with the camera out (side mount - phosphor retracted, bottom mount - viewing screen down).
3. Reduce beam brightness: Use a smaller spot size (controlled by condenser 1). If your largest spot size is 1, try 5 or 6. You may also want to use a smaller condenser aperture. Your diffraction pattern should be bright enough to see details, but not bright enough dim to burn anything.
4. Minimize "camera in" time: Using the first three precautions you should be able to get a nice pattern on the TEM viewing screen. Then put "camera in" for a short time. Collect a final image and go to "camera out" right away.

Bright part of the central beam blocked by pointer.

**Sensitivity and Grayscale adjustment:** Your Default Settings for imaging may have more sensitivity than is needed for diffraction imaging. If AMT complains that it is "Too Bright" even when you follow the precautions above, you can set the camera's sensitivity lower (see also the topic page "Diffraction Settings"). For survey mode set the gain to one and reduce the exposure time. The minimum exposure time for safety will vary depending on the camera, but you can move it down toward 30 milliseconds (call AMT for more specifics). When you have Survey sensitivity set, click the "Balance Camera Exposures" button to make the other imaging modes’ sensitivities approximately equal to Survey's (for precise balancing see the topic "Settings->Camera Settings and Control Window->Exposure Times and Gains").

Getting weak rings and spots to show up often requires manually adjusting the contrast in AMT. Turn the Autogain "Off" and move the black, and especially the white, slider bar to maximize contrast.

**Saving:** It is usually best to save diffraction images as 16-bit tiff files. There are often hidden spots
or rings that can be enhanced better in the bigger (16 bit) files. To bring out fine details, open a saved image in ImageJ. On the upper menu, choose the function "Process -> Math -> Gamma. 

Set the Gamma to about 0.4. Experiment by adding or subtracting tenths.

If your camera has "Low Light Mode" vs "Diffraction mode" choice under "Display" on the upper menu, change it to "Diffraction" mode for diffraction. This prevents overloaded pixels from "blooming" onto neighboring pixels. Don't forget to change back for normal imaging. Reopening the program will also bring back normal (Low Light) mode.

**Diffraction Settings**

Those who do diffraction often and analyze images offline can increase efficiency by creating a separate set of camera settings for diffraction using the "Camera Settings And Control Window". The settings described below are designed for uniform quantitative calibration. (You can get "prettier" pictures using Gamma and non-zero thresholds.)

For information relevant to quantitative analysis of diffraction images, see the AMTHelpFiles chapter Data Analysis - Bit Depth of Images.

1. Set record gain to 1. Use record exposure time to adjust brightness.
2. Set white and black thresholds to zero and run with AutoGain ON.
   This disables the Autogain's rescaling, but leaves corrections in place. (Note that zeroing Thresholds disables Tails as well.)
3. Set gamma to 1 (neutral).
   These steps should give you quantitative data in the sense the camera becomes a light meter - as long as the dark field and background correction images are constant. Absolute intensities become meaningful and can be calibrated.
4. Use as many final integrations as possible, keeping total exposure time below 3 seconds.
5. Save these conditions for diffraction - or some name that you like. The saved conditions will contain the zero thresholds. Do not use this condition as your default unless you do only diffraction.
6. Acquire a dark field (no beam) and background using a very uniformly spread beam. I believe that the background should be taken once and only once to normalize the radial falloff of the lens. (Phosphor graininess should not be important in diffraction).
If you are measuring absolute intensities picture-to-picture, do not repeat the background acquisition, unless you can measure the beam current independently and take new backgrounds under the same beam intensities (within your error tolerance).

But note: relative intensities, within a picture will not be degraded by a new background.

7. Note that your saved backgrounds and dark images are valid only after new "diffraction" conditions are saved or recalled. Check your display to make sure you are saving to the right place.

8. As a precaution, save a copy the entire folder containing your settings and correction images. These can be found in c:\amtcommon\config\Settings\name of settings file
   There will be one .txt file and eight .bin image files in this folder.
   In fact it would be good idea to back up the entire Config folder to keep all your settings.

9. Save your diffraction images in 16-bit format.
Saving Images and Cases

Now that you're experienced taking pictures, you probably want to save them. There's two methods in AMT for saving images. The first is the familiar "File -> Save As" method. For a more efficient method of collecting and saving multiple images quickly use the Case Study protocol.

Contents

Microscope Information Window
Saving via "File Save As"
Changing the Default Saving Path
Using Case Studies
Archiving Cases

Microscope Information Window

Whichever method you choose for saving images, before saving you will encounter the Microscope Information window. This is a collection of information which will be stored with your image. The items you check will be displayed at the bottom of the image when it's opened in an image processor and in a print. A saved image's information can also be displayed in the AMT program by clicking (on the upper menu) "Display" and then "Show Saved Image and Caption".

If your scope has communications, the Magnification, and possibly the Voltage, stage X and Y and Tilt, will be automatically entered when you collect your final image. For scopes without communications you need to type in the correct values.

There is room for two optional Caption lines. The main reason for the Keyword items is that all this information about the image is saved to a database (C:\AMThistory\AMTImagingDatabase1.rtf), besides being saved to the image file. You can use Keywords to facilitate searches for images or data. If you check the Keywords they will also be displayed in a processor, but not on separate lines. The "Facility" name is set in "Utilities->Special Options" on AMT's upper menu.

If you're using the Case Study protocol the window will display a path and a filename, which is the case name plus an auto sequenced number.
Near the top of the window you choose whether you would like the saved image to display the "Print Mag" (e.g. "Print Mag:  19600x @ 7.0 in") or Pixel Size (e.g. "Cal : microns/pix") or neither. "Printer Units" sets the print width, using either inches or millimeters. This number is used by whatever image processor you print from. (Note: The "Print Mag" displayed under the image is calculated for a print of the width you set here. If, when printing, you click "Fit to available space", the Print Mag displayed on the printed image will be wrong. If you want a wider print, it is best to set it wider here.)

The first item in menu at the top of the window, "KeyboardCommands" displays two keyboard shortcuts when clicked. The "SwitchMode" item changes the "Imaging Mode" from imaging to diffraction, which changes "Magnification" to "Cam Length". "Add File Options" allows one to add a suffix to a filename (case study only) or create a text file with all the image's information (Not available in Case Study).

When the information in the window is complete, click the "Save With Caption". This saves all the information in the window. For a shortcut back to live imaging, use the right button on the mouse for this click. This will automatically restart live imaging after the image is saved.
Saving via "File -> Save As"

Users with Windows computer experience are familiar with saving files this way. "File" is the leftmost item in the top menu. When you click "Save As" the Microscope Information Window discussed above will appear. After you click "Save With Caption" in that window the following window will appear:

![Image of Save As window]

Here you are asked to choose a location folder for the image, and to give the File a name. You can also choose what type of file to save. The default type is a Tiff image file. The default place for saving images this way is the folder "C:\Images". To change this to a different folder see the topic "Changing the Default Saving Path".

After an image is saved, it, including the attached captions and metadata, can be viewed in a Utility Display window. See the topic "Show Saved Image and Caption".

Changing the Default Image Saving Path

In "Preferences" you can change the default saving path for both "File -> Save As" image saving and for saving new cases. This can save a lot of time if you save most of your images or cases to a folder other than the AMT assigned default location.

On the upper menu, click "File -> Preferences -> Image Save Options -> Set Default Image Path" or "Set Default Case Path".

![Image of Preferences window]

After this selection you will get the following window for typing in the default path:

![Image of default path window]

Type in your preferred default path and click "OK".
Using Case Studies

The first step in using Case Study is to create a Case. To do this go on the menu to "File -> Case Study Create Or Resume".

After this selection the "Restart Case or Open New Case" window will appear. It contains windows to enter information for a new case, and lists the cases that are already created. It also has buttons for choosing how the cases will be ordered in the display. Let's look at the new case entry windows first.

The path for a new case defaults to the folder "C:\CaseStudies". You can use a different path. Click on the "Browse for Folder" button to navigate to the folder where you want to put the new case. The default path for saving new cases can also be changed, in "Preferences" (see the topic "Changing the Default Saving Path").
After entering a name for the case (avoid using spaces or periods), you can "Choose Image Format" for saving. The default is 8-bit Tiff images, which is best for most normal imaging. Sixteen bit Tiffs are good for doing quantitative analysis, of gray levels for instance, and for enhancing diffraction images. However, many image processors do not handle the larger files very well. JPEG images are the smallest files, which is useful for emailing, but they are a "lossy" file, losing information every time they are resaved. Therefore, cases that save JPEGs will also save Tiffs. The quality (degree of compression) of the JPEGs is set by click the upper menu item: 'File -> Preferences -> Image Save Options -> Set JPEG Quality'.

When your case information is entered click the "Update and Start" button at the bottom of the Case Study window. At this point you have created and saved a case, but no images are saved to it. To save an image, click on the file cabinet icon on the lower left of the AMT display.

When you click the file cabinet icon, the "Microscope Information Window" will open. See the topic page "Microscope Information Window" for an explanation of its controls. What we show here is the unlike its appearance during the "File -> Save As" operation, the window now shows the path which you have set up, and the image’s file name, which is assigned by the case. The file name is the case name plus a number, which is automatically sequenced.

To resume a different saved case, go to "File - Case Study Create or Resume" to reopen the Case Study window. Double click on one of the listed saved cases. Make sure that the path and case name make it into the entry windows. Then click "Update and Start".
The "Restart Case or Open New Case" window also allows you to choose how the saved cases will be ordered in the list.

Archiving Cases

If you do a lot of cases the list of previous cases to choose from can become very long. You can put some of the active cases into archive which will get them out of the active case list. They'll still be saved and you can retrieve them to the active list just as easily. To open the Archive Manager, click "File -> Case Study ->Select Case Display Options -> Case Archive Manager".

After this selection the Archive Manager Window will open:
With that tool case names are easily moved from the active case list to the archive and back again. The case folder and its images are not moved, only where the case is listed in the AMT program.

**********************************************************************

ADVANCED TOPICS

This section is for advanced users seeking more information.

Contents

Image Properties And Corrections
Lattice Imaging With Bottom Mounts

**********************************************************************

Image Properties and Corrections

The pages in this chapter are about how information for each pixel is collected, manipulated and stored. It is intended for users that need technical specifications for things like flat field correction, frame averaging and bit depths. Those printing these files as a general manual for new users can skip this chapter.

Contents

Bit Depth Of Images
Frame Averaging and Summation
Physically Based Flat Field Correction
Mag Factor In TEM Digital Imaging

**********************************************************************

Bit Depth of Images

This page describes the collection and storage of information in binary registers. The information can be important for those who want to electronically analyze images. The data is collected as follows

For both live and recorded data

1. 12-bit image data is generated by the camera and sent to the computer with two "8-bit bytes" per pixel.
2. The pixel's values are forced to be justified "high" so that the most significant data is in the high byte. This means that the first 4 bits of the low byte are zero.
3. This does not make the data "perfect" in the sense that the maximum value is 65535. That comes later.

For live data only

1. Only the most significant byte is used throughout the video chain. That is: the live data is 8 bits. This matches the SNR requirements of the TEM and display and allows faster data handling. 
2. The raw data is dark field and background corrected for each frame, and the histogram of the corrected data is shown in the graphics window. This is unaffected by gain and offset. (So the "red" line does not change with White/Black/Gamma.)
3. The corrected live data is routed through an 8-bit video (Look Up Table) LUT for display. Since the data is not changed by the LUT all grayscale mapping is reversible.

4. Maximum data values of 255 are possible but usually neither achieved nor desired.

For recorded data

1. All recorded data is summed in an array S of 32 bit deep unsigned integers. After integration S is divided by the number of integrations and transferred to a 16-bit data array. At this point the data is justified "high" but the maximum of 65535 is still not necessarily attained in the image. It is simply the 16 most significant bits of the "raw data."

   Ideally, if the 12 A/D (analog to digital converter) were perfect, this array would lose some information for integrations of greater than 16 frames (16 x 12bits = 16 bits). In practice the A/Ds are not noise-free and the process can tolerate ~64 integrations before this becomes a concern (and then only for a near saturated image).

2. The data is then dark field and background corrected with 32-bit arithmetic. The maximum of 65535 is still not necessarily attained in the image.

3. If there AutoGain (and the thresholds are > 0) then the data are rescaled so that the maximum is 65535 and the minimum is zero.

4. The rescaling procedure was initially developed in conjunction with exposure balancing. Ideally we "balance" the camera exposure times and gains so that setting the exposure in the live conditions automatically produces the proper recording exposure levels. Remapping the data using the AutoGain criteria gives a matching contrast level. In fact, the use of "tails" makes this procedure more forgiving and will produce matching contrast even if the exposures are not balanced.

5. This procedure (coincidentally) made our images compatible with early versions of Photoshop and some other software, which could not "see" the lower byte of a 16-bit TIFF image. Our competitor who justified the data "low" had big problems with this.

6. Setting Gamma to 1 and setting the thresholds to zero (with AutoGain ON) will disable rescaling but still give you the corrections. (Note that zeroing thresholds disables tails as well.)

This should give you quantitative data in the sense the camera becomes a light meter - as long as the dark and background images are constant. Absolute intensities become meaningful and can be calibrated.

It is also possible to disable background and dark field corrections, but I do not recommend this.

Histogram "Smoothness"

1. In principle dark field and background corrections add to the total uncertainty of the measurement and reduce the dynamic range of the data.

   Corrected Image = <mean of Back-Dark> [(Image + e1) - (Dark + e2)]/[(Back + e3) - (Dark + e2)]

   (error/Corrected Image)2 = [ (e1 + e2)/(Image - Dark)]2 + [(e3 + e2)/(Back-Dark)]2

   However, we integrate both the background and dark images during acquisition to keep e2 << e1 and e3 << e1 and Image ~ (Back-Dark) so that this loss should be insignificant.

2. Any integration will increase the dynamic range by the SQRT of the number of integrations.

3. So we expect that the histogram will look relatively smooth at > 10 bits for a reasonable well illuminated image at the unity gain. We would expect gaps to appear for high gains and poor illumination.

Specific Suggestions for Diffraction

The bit depth information of images suggests using a separate set of settings for diffraction imaging. See the AMTHelpfiles chapter on Diffraction Imaging.

Frame Averaging and Summation
Typically, TEM image quality is limited by beam statistics, where the signal-to-noise (SNR) per pixel is equal to the square root of the electron count assigned to the pixel. The electron counts per pixel are limited in the CCD by the well depth of the sensor. SNR can be increased by mathematically summing or averaging pixel values frame by frame.

**Live Modes:** In live imaging the camera system offers a Quality Mode, which frame averages the live image using a recursive filter:

\[
R(x, y)_I = \left[ \frac{255}{4095} \right] \ast \left[ \frac{r(x, y)_I + (n-1) R(x, y)_{I-1}}{n} \right]
\]

where
\( r(x, y)_I \) is the incoming frame \( I \)
\( R(x, y)_I \) is the frame averaged value of the \( I \)th frame, and
\( n \) is the frame averaging constant – as specified in the “frame average” in the Quality Setting in the "**Camera Settings Control**" form. Note that the result is normalized to 8 bit (256 levels) to accommodate the speed requirements of live display and processing.

**Recording Mode:** In the recording modes the camera system frame integrates multiple frames so that

\[
R(x, y) = \left[ \frac{65535}{(n \times 4095)} \right] \sum r(x, y)_I
\]

for \( I = 1 \) to \( n \), where
\( r(x, y)_I \) is the incoming frame \( I \)
\( R(x, y) \) is the frame averaged value of the \( I \)th frame, and
\( n \) is the number of frames in the sum as specified in the “Record Integrations” in the "**Camera Settings Control**" form.

This result is normalized to 16 bits (65536 levels), which allows internal calculations to be done at high precision.
The effect of multiple integrations is to increase the number of counts per pixel, which decreases the statistical noise. This is a physical effect that can be modeled. To first order the signal-to-noise ratio will be proportional to the square root of the integrations. You get a 40\% improvement from 2 integrations, 100\% from 4, 180\% from 8 and 300\% from 16. The most improvement per time unit is from 2 integrations. Integrations greater than 8 are rarely useful, because the noise becomes less than the detectability of the display and printer. Mathematically, improvements will occur up to 64 frames. These images need to be recorded in 16-bit TIFF format.

The improvement in signal-to-noise ratio is physically limited by the instability and drift in the specimen. It is also limited by the patience of the user.

### Physically Based Flat Field Correction

The flat field correction normally used in AMT images is a combination of dark-field subtraction and gain normalization that accounts for multiple non-uniformities in the image.

#### Dark Image

Images are usually “flat-field” corrected. In the first step of this correction the dark image is subtracted from the incoming, raw data. In versions before 5.4.2.200 the dark image is collected by the menu operation. This function collects a base image with no light or electron signal. The program collects dark images appropriate for Survey, Focus, FFT, Super and Record modes. They are stored in `c:\AMT\common\config\Settings\DefaultSettings` or the other specifically named settings folders, as appropriate. Dark images are frame integrated 8 to 16 times and then normalized to 16-bit format. The dark image has both systematic and random components.

The random component is almost always much less than the statistical noise of the electron beam. The “DC” part of the systematic component can be significant for very low signal images where the raw signal is not 10 or more times larger than the DC component. For well illuminated specimens the dark image correction is not significant.

Dark images vary to a small extent with exposure time and are proportional to camera gain; so it is best to acquire them for each set exposure conditions. Dark images are very stable; so that they are valid for at least a year under a given set of gain and exposure conditions – unless some physical change is made to the camera electronics.

The dark image is always subtracted from the raw data (unless the dark image file is deleted from the particular AMT common folder). So the first step in the flat field correction is:

\[
R'(x,y) = R(x,y) - D(x,y),
\]

where

\(R(x,y)\) is the raw camera data, \(D(x,y)\) is the dark image and \(R'(x,y)\) is the dark corrected image.

#### Background Image

The second part of the flat-field correction is background normalization. The operation adjusts for the illumination variations in the lens and phosphor. Background correction assumes a linear model for the modulation of the raw image. That is the raw image is the product of the intensity of the ideal image and the modulation function.

\[
R'(x,y) = I(x,y) * M(x, y),
\]

where \(I(x,y)\) is the ideal image, and \(M(x, y)\) is the modulation of the image due to imperfections the optics, phosphor and TEM.

Background correction requires the imaging a uniformly illuminated phosphor with a spread beam. The collection of the Background Image is accomplished by a menu item:
Background images are frame integrated 8 to 16 times and then normalized to 16-bit format. The modulation function is computed from the background image as follows:

\[ B'(x,y) = B(x,y) - D(x,y) \]

Where

- \( B(x,y) \) is the Background value at each point,
- \( B'(x,y) \) is the dark corrected background at each point, and
- \(<B'>\) is the mean of \( B(x,y) \).

Finally the ideal image is:

\[ I(x,y) = \frac{<B'> * R'(x,y)}{B'(x,y)} \]

Background images vary mostly with mechanical drift of the system; so it is best to acquire them every day. The linearity assumption can also break down under extreme illumination conditions and where illumination profile in the TEM varies with magnification. This generally is not good operation, so spot size and apertures should be varied to avoid it.

**Magnification Factor in Digital Imaging**

There is much confusion about the "mag factor" which is often specified by the TEM beam projection alone. From this perspective a bottom-mount camera has only \(~115\%\) times the magnification of a negative (mag factor = 1.15\%). Also by this standard a side-mount camera would have a mag factor of 0.3. Both are misleadingly low and do not correspond to user experience, because they do not account for the size of the detector (capture size) or field-of-view, which is generally much smaller than a negative.

All digital output devices are about the same size as photographic prints. But the smaller size of digital camera detectors results in more enlargement than needed for a photographic print. A meaningful "mag factor" must include this enlargement value.

To compare magnification factors you should use a common observable reference: negative, viewing screen, monitor, or print.
**Magnification** is the TEM magnification at the detector position multiplied by the *enlargement* of the the print. The enlargement is the ratio of the print size (~75mm) divided by the *capture size*, which is either the size of the phosphor or the size of negative.

\[
\text{TEM Mag} \times \frac{\text{Print Size}}{\text{Capture Size}} = \text{Final Mag}
\]

<table>
<thead>
<tr>
<th>Mag (x)</th>
<th>Print Size</th>
<th>Capture Size</th>
<th>Final Mag</th>
<th>Camera Placement</th>
</tr>
</thead>
<tbody>
<tr>
<td>3000</td>
<td>175/24</td>
<td></td>
<td>21,975</td>
<td>Advantage HR</td>
</tr>
<tr>
<td>6000</td>
<td>175/24</td>
<td></td>
<td>6000</td>
<td>Viewing Screen</td>
</tr>
<tr>
<td>10000</td>
<td>175/75</td>
<td></td>
<td>23,333</td>
<td>Negative</td>
</tr>
<tr>
<td>11000</td>
<td>175/24</td>
<td></td>
<td>72,500</td>
<td>Advantage EK5</td>
</tr>
<tr>
<td>11000</td>
<td>175/33</td>
<td></td>
<td>68,333</td>
<td>XR80B/XR40B</td>
</tr>
<tr>
<td>11000</td>
<td>175/60</td>
<td></td>
<td>29,157</td>
<td>XR80C/XR40C</td>
</tr>
</tbody>
</table>

---

**Diagram:**

- **Camera**
- **Side-Mount**
- **Beam Projection**
- **Viewing Screen**
- **Negative**
- **Bottom-Mount Phosphor**
- **Bottom Mount Camera Choices**
Lattice Imaging with Bottom Mount Digital Camera

1. The phosphor pixel size determines the minimum magnification needed to see lattice. The minimum case has a bright region centered on one pixel and the dark region centered on its neighbor. So an absolute limit of 2 pixels for each “period” of the lattice oscillation.

2. The ERB camera has a ~23 micron pixels. So, a 3Å lattice period would need to project to 46 microns on the phosphor. This corresponds to a minimum magnification of \(46 \times 10^{-6} \text{ m} / 3 \times 10^{-10} \text{ m}\) or 150,000x, if the lines are horizontal or vertical.

3. Slanted lines need higher magnification. The worst case is 45 degrees, where the lattice period corresponds to 65 microns. To see lines at this angle the minimum magnification is 220,000x.

4. The camera is below the film plane so that the magnification at the camera is 10 to 20% higher than the “dial” or “film” magnification. Thus, 200,000x should be able to resolve 3Å lattice in the ideal case.

5. But the world is not perfect.
   a) This model assumes that the lattice sampling is perfectly synchronized with the CCD array, which is nearly impossible to achieve. There will always be sharing between adjacent pixels. There is also the possibility of Moiré patterns, if the minimum magnification is used and there is only a small difference in lattice and CCD periods.
   b) The model assumes high contrast in the image and nearly perfect response of the camera. Neither is true.

6. The general “rule of thumb” is to use ~2 to 3 times higher magnification than the ideal. This means that you should be more comfortable shooting 3Å lattice at ~500,000x with a bottom mount camera.
   [Note: These values will be good for most bottom mount 1k cameras made by us or our competitors. Some 2k cameras have smaller pixels (i.e. Gatan’s UltraScan = 15 microns, AMTXR60B = 12 microns); so a lower magnification can be used. Our large field, 7 mpixel bottom mount XR100 has 24 micron pixels; so the upper resolution limit is the same as the 1k but the field is 2.6x larger (Mag factor is 2.6 smaller).]
Camera Settings and Control

Your system has a multi-mode camera: So it is possible to adjust gain, exposure, binning conditions and record integrations. During installation a general purpose set of default conditions are set up. However, to optimize results under a variety of conditions, other settings are often needed. This section describes how to make changes to the camera and save them for use later on.

Contents

Set/Save
Recall
Sample Region
Exposure Times and Gains
Thresholds and Tails

Set/Save

The "Set/Save" button at the lower right of you AMT display window opens the "Camera Settings Control" window. This window is where most of the parameters of your camera are set. You can experiment with parameters without changing anything permanently if, after you change a parameter, you click “Apply For Now Only” to close the window. If you find some settings you want to save permanently click on "Apply And Save Conditions To File". If saving permanently you can give the settings a new name, and create as many sets of settings as you like. Changing the default conditions requires the password.

Among the items controlled here are Exposures times (in milliseconds), gains, record integrations, live frame averaging (Quality Setting), Autogain Sample Region, contrast settings (Thresholds and Tails) and Display Size.
Exposure and Gain Control
The exposure time (given in milliseconds) and gain settings are analogous to exposure time and film sensitivity on a film camera. They control the speed and sensitivity of your camera. For more on this subject, including balancing sensitivities between modes, see the page “Exposure Times and Gains”

Record Integrations and Quality Settings
These are similar operations where multiple frames are averaged together to improve signal quality. The Quality setting work on the live image and the Record Integrations settings apply to Final images only. Drifting Specimens: If specimen drift is a problem, try lessening the Record Integrations.

Contrast Control
The AutoGain function manages camera’s contrast and uses it in the grayscales where you actually have sample. It uses the Black and White Thresholds to determine the contrast window. Increasing the Thresholds can make the image more contrasty. Then Tails are added to each side of the windows. Tails use is more subtle, but they have an effect opposing that of Thresholds (See also Grayscale Manipulation.)

Sample Region
The Autogain’s contrast control sets its range (the width between the vertical green lines on the histogram) by sampling a rectangle within the image. Its size is determined by the Sample Region setting. The default setting is usually 95%. If white or black features, such as grid bars, on the periphery of your image, are from “hogging” the contrast, choose a smaller sample region, say 40%. The Autogain will then set itself looking only at the center 40% of the image, and so will ignore the periphery for setting contrast. It is helpful to use a non-zero value of the Tails when the sample region is less than 100%.

Auto-Sharpen Level
If you do sharpen images, AMT sharpening is probably better than doing it in an image processor, because it is native. You can choose sharpening levels of 1, 2 or 3.

Apply For Now Only
This applies the changes until the program is restarted, or until the user Recalls a set of settings. It does
not permanently change any parameters.

**Save and Apply**
This saves the changes you have made in this window to be loaded later. You can create settings with a new name or overwrite one of the standard ones. The Default Settings are password protected. Each set of settings has its own background and darkfield. If you use settings other than the default ones, you need to acquire a background while in them. Creating settings with new exposure and gain values also requires acquiring a new darkfield.

**Recall**

The Recall button is right next to the Set/Save one. When you click it you will be given a menu of the stored configurations of settings, each of which have been created using the Set/Save button.

The Default Settings are what your program opens with, and they're the ones you use most of the time. The MediumMag and HighMag have more sensitivity, but are a little slower and noisier. Recall these settings when you don't have enough light (beam) for normal imaging in the default settings. They can also be used at low mags if you have an especially sensitive sample you want to protect. The more sensitive settings usually have the number Record Integrations set to one, because stage drift is more of a problem at higher mags. If your sample is not moving, you can bump up the Integrations to reduce noise.

The LowMagSettings have less sensitive settings in case they're needed for low mags. On many systems the default settings are fast enough for low mag work, so the LowMagSettings have the same exposures and gains. The LowMagSettings make it possible to store a separate background for low mag work. In some scopes the shape of the beam changes a lot between say 1.2KX and 6KX, and they find themselves taking new backgrounds when they navigate between these mags. They find that having a separate stored background for low mag saves them time.

Each set of settings has its own darkfield and background. When you take your daily background it will be in the Default Settings. If you use other settings, they will need to have the background refreshed also. (The darkfields are good for a year or two.)
The set of settings you're using is displayed on the main user display, above the Set/Save and Recall buttons.

**Sample Region**

The "Sample Region" is the area which the AutoGain samples to set the contrast parameters. Pixels in this region are the make up the red graph in the histogram display. Normally this sub region is set between 80% and 95% the field-of-view as specified in the Camera Setting Control Window. The user can select values ranging up to 100%. This sub region is centered in the field of view.

A sample region which is centered allows image contrast calculations to ignore extreme values of light or dark at the edges of the image. If light or dark extremes, such as a grid bar, are entering into the sample region from outside it, and making the contrast washed out, you can eliminate its impact on contrast by choosing a smaller Sample Region.

Small window sizes tend to make harsher contrast, probably because of reduced statistics. Empirically, we find that increasing tails or using gamma helps.

**Exposure Times and Gains**

Exposure time and gain in a CCD camera are analogous to exposure time and film sensitivity in a film camera. They set the speed and sensitivity of your camera. The three live camera modes and the final (record) image mode, each has its own settings for exposure time and gain. Open them with the "Set/Save" button.
Speed vs Sensitivity
Speed and sensitivity are opposing ideals. A faster camera needs more beam intensity. Usually your default settings are set up to be fast, to facilitate scanning and focusing, but sensitive enough to cover your usual mag range without having the beam so focused that the edges are dark. For higher mags, or for very sensitive samples, MediumMagSettings and HighMagSettings are provided. They provide more sensitivity but run slower, and they may see a little more noise. LowMagSettings usually have lower sensitivity (more speed) than your Default settings to facilitate a brighter beam at low mag. Sometimes LowMagSettings with the same sensitivity as the DefaultSettings are created which serve as a place to store a separate background for low mag.

Balancing Sensitivities
The three live modes and the final image mode need to have their sensitivities "balanced" so that your light level remains constant as you switch modes or go from live to final imaging. The sensitivities for your Default, Low, Medium and High Mag settings have been balanced by the installer. Balancing by the user might be needed if new settings are created, or the check balancing on the normal settings. A quick but imperfect, way to balance exposures and gains is with the "Balance Camera Exposures" button which is to the right of the exposure and gain values. This accepts the exposure time and gain of the Survey mode and adjusts those of the other modes to match it. For values close to the Default and MediumMag settings this method gives a pretty good approximation. For very fast or slow settings, or for precision balancing, one needs to use manual balancing.

More Sensitive Settings
To create a setting with more sensitivity, start with the Focus mode, since that mode usually limits sensitivity. Using the current most sensitive settings, in focus mode, put the histogram to the left of center, say at 25% of the width of the box.

Then bump up the focus mode exposures and gain, click "Apply For Now Only", return to live imaging and see where the histogram is. If it's near the center you're ready to do manual balancing, using focus mode as the standard.
If you want super sensitive settings, and don't need to use focus mode during imaging, you can ignore focus mode and use Survey mode as your standard.
If you are creating Default settings for a new camera setup, a Focus mode with Exposures of 150ms and a Gain of 2 (sidemount) or 3 (bottom mount) is usually a good standard to start with.

Less Sensitive Settings
Be careful not to set sensitivity so low that you burn the phosphor. If Survey Exposures gets below 45, check the beam with the camera out to make sure it is spread out past the TEM viewing screen, and that the condenser aperture is in place.

Manual Balancing
1. After you have set a standard (one mode with the correct sensitivity for the new settings), the next step is to set the Black Threshold and White Threshold to zero to facilitate balancing. This keeps the AutoGain function from interfering with the histogram display. Don't change the Tails.
2. Take your sample is out and turn background corrections off.

3. Using whichever live mode is your reference point (standard), put the histogram peak in the center of the display box, maybe under the "O" in "Off".

4. Now switch to the other live imaging modes and record mode (Final Image). Make a note for each mode of whether the histogram is higher, lower or about the same as where it is in your reference mode.

5. Then click Set/Save to go back to the camera control window and there make adjustments to the exposures and gains of your non-reference modes to get their histograms nearer to that of the reference mode. You can type in new values for the Exposures and Gains. The Gains can be changed in increments as small as one tenth, using a decimal point. It is usually best to limit "Record" exposure time to about 1 second (1000ms) and use the Gain to make increases after that.

6. After your adjustments click "Apply For Now Only" and repeat steps 3 through 6. When the histogram moves very little as you switch between modes set the Thresholds back to 10 and
then click "Apply and Save Conditions to File". The settings can be saved with a new name or some current settings can be overwritten. After you create new settings you need to collect a new darkfield and background for those settings.

**Thresholds and Tails**

**Black and White Thresholds**
The AutoGain assigns pure black or pure white values to pixels at the lowest and highest values of a histogram. Those pixels under the red graph, but outside the vertical green lines are kicked out into pure black or white. How many pixels get kicked out depends on size of the "Thresholds". If thresholds are set to zero none get kicked out - all 256 grayscales that the camera receives are reported as is.

![Thresholds = 0 Tails NA](image)

The white and black limits are designated by vertical green lines. All values below the black limit are assigned zero and all values above the white limit are assigned 65535.

The thresholds tell the green lines how far up the slopes of the histogram they should go. Higher thresholds move the green lines closer together, concentrating the camera's contrast on the grayscales where most of the pixels are, and kicking edges out into pure black or pure white. The default thresholds are 10, but some users like higher values, which gives a more contrasty image.

![Thresholds = 10 Tails 0](image)

The mapping between black and white is shown by a diagonal green line drawn between the green vertical line. This line is straight for gamma = 1 and sigma = 1 in the live image. For values of gamma or sigma, it is curved in live mode (See also "Grayscale Manipulation->The AutoGain Function".

![Thresholds = 10 Tails 40%](image)

Note that the gamma during live operation is carried as the “base” for the final image. So the diagonal line shown in the final image is always straight immediately after acquisition. The actual (based plus added) gamma value is shown in the gamma control screen, however. The system remembers the base values for the session until it is changed by the user.

**Tails**
The “Tails” move the green lines away from the center by a percentage of the distance between them. This takes some pixels that were pure black or white and puts them into the gray. Positive Tails reduce the contrast of the image, and can be used to reduce “Blotchiness” caused by too many pure white or pure black areas.

Negative tails increase the number of pixels which are pure black or white. If you have some almost white features which you want to be pure white they will often show up on the histogram as small extra peak, such as in the picture below. Use a negative tail to move the right green line to the left, making the features pure white.

![Tails example](image)
**DISPLAY OPTIONS**

The AMT Image Capture Engine has lots of tools to change the way things are displayed during live and final imaging and while measuring.

Contents

Changing Image Displays
Show/Hide Options
Continuous Mag Read  (TEM communications)
Preferences Display Characteristics

**Changing Image Display**

The AMT Image Capture Engine has lots of tools to change the way things are displayed during live and final imaging and while measuring. Most of these options are accessed either the "Display" or "Proc/Meas" menu items.

**Refresh Display**

This button is not needed often. It allows the user to refresh the display of a window.
Contrast Inversion

Sometimes a user wants an image to be displayed with black pixels appearing as white and white pixels appearing as black, like a negative. This kind of display can be helpful when counting gold particles, for instance. The Display menu provides buttons for inverting the display, either just in the live image (with final images being normal), or on both the live and final images.

To invert contrast, click the "Display" button on the upper menu and, on the drop down menu, click "Select Contrast Inversion".

The contrast options window allows inverting contrast on live image only, live and final images, or neither.
After contrast is changed the buttons become buttons for returning to normal contrast.

**Center Cross**

The Display menu provides a number of alternatives for showing a white cross over the center of the image. One can show the cross on the Live image only, on all final images or on just this final image.

After a center cross option is activated, the clicked button becomes a switch for removing the cross.

**Show Saved Image And Caption**

Another item in the Display menu gives you the option of displaying the image you just saved, including the captions, Mag and HV listing, scale bar, and other saved information, in a utility window. To use this options one first needs to be displaying an image that has been saved.

When you select the menu item the image and captions will open in the "Utility Display" window. To close the window, click "Options -> Hide Utility Display".
Undo Graphics

This option is under the "Proc/Meas" menu item. After adding graphics to a final image by measuring, drawing grid lines or creating a text box, clicking "Undo Graphics" will remove them to restore the original image.

Draw Rectangular Grid

Having a regular grid on your image can facilitate counting or identifying features. To draw one click "Proc/Meas" and select "Draw Rectangular Grid".
A window opens where you select the number of horizontal division for the grid.

Darken

The "Darken" menu item temporarily darkens the entire monitor. It might be used while collecting a dark image, for instance. To bring back the display just click anywhere on the monitor.

Show/Hide Options

Near the right of the menu bar is the button for the "Show/Hide" options. With these options you can make visible or invisible the Live Scale Bar and Control Panel, or change the size of the Mag Display.
Show/Hide Control Panel

One option under "Show/Hide" is for the Control Panel on the right and left side of the image. Hiding it might give you a more uncluttered view of the image.

Image with the Control Panels gone
Show/Hide Large Mag Display

By clicking this item one can show or hide the large mag readout at the lower right part of the display.

Show/Hide Live Scale Bar

A scale bar can be displayed in live images. This scale bar is not saved with the image. It is for use in live or final images, but only in the AMT display. If you have TEM communications and continuous live mag updating, the scale bar will automatically change size or dimension when you change mag on the TEM. Otherwise it will change size after you manually enter the mag with a saved image.

The Scale bar normally appears in the lower left corner of the image, but it can be moved anywhere by right clicking a location. When the Live Scale Bar is showing, the menu item become "Hide Live Scale Bar".

Other Show/Hide Options

"(Show/)HideMeasList" controls the Measurements window, which can get hidden behind the AMT display during measurement. "FFT Control" has options for Show/Hide and size of the FFT window. There are also options to show image collection and saving times, and information about the Show/Hide feature.

Continuous Mag Read

"Preferences -> TEM Communications Options -> Enable/Disable Continuous Mag Read" turns on and off the continuous live update of the mag display during live imaging. If it is off, in scopes with communications, mag will be updated when a final image is collected. The reason for providing the choice is that on some scopes the live imaging display is smoother without continuous mag updates.
Below is the mag display, which gets updated.

**Preferences -> Display Characteristics**
In File -> Preferences -> Display Characteristics there are a number of choices to be made for the image display. These include:
- Making the default for live imaging "Speed Live" or "Quality Live".
- Setting the Measurement Marker and Cursor.
- Setting the Form Position on Screen (Set where AMT opens on you monitor[s]). Prompt to shutoff Main Display (For TV only display).
- Select Font - For on image text. Set Measurement Line Thickness. Scale Bar Customization.
Contents

Speed Live or Quality Live as Default
Set Measurement Marker and Cursor
Select Font for On Image Text
Scale Bar Customization

**********************************************************************

**Speed Live Or Quality Live As Default**

When you open and use AMT it will automatically start imaging with either "Speed Live" and "Quality Live". Speed Live is faster, but Quality live averages together several frames in live mode to average out noise. Quality Live often gives a prettier live image, but the tradeoff is that imaging runs a little slower. You can toggle between them with the "Speed/Quality Live" button. The choice you make in Preferences is which one the program opens with.

Here's where you would change the speed during live imaging:

**Set Measurement Marker And Cursor**

The *Measurement Cursor* surrounds the point which the mouse moves to points to measure the distance between them. The point can be surrounded by a circle or by crossed by crosshairs.
The **Measurement Marker** marks the endpoints of a line segment after it has been measured. The Marker can be Small, Medium or Large.

Select Font For On Image Text

The style, size and boldness of the font placed by the Annotation Text Tool, Measurements, and Scale Bars on Live and Saved images, are things you have some control over. For the Caption Bar, at the bottom of a saved image, including the Saved With Caption scalebar, you can control font and boldness but not size. For other adjustments to the Scale Bars, see the "Scale Bar Customization" page.

To change the font, select from the upper menu the item "File -> Preferences -> Display Characteristics -> Select Font".
The Font Selection window which opens gives a choice of six font styles to choose from. You can also choose "Bold" or "Regular". The On Image Font Size Multiplier defaults to "1" and allows setting font size anywhere between 0.5 and 2.00.

Scale Bar Customization

The Scale Bar Customization utility controls Scale Bar Thickness and Maximum Scale Bar Size for scale bars "Saved With Caption" in the Caption Bar and for those "Saved Without Caption" which appear on the image itself. For scale bars appearing on the image, the Customization utility also allow you to move it left or right by a small amount.

To access the Scale Bar Customization utility click "File -> Preferences -> Display Characteristics -> Scale Bar Customization".
This bring up the Scale Bar Customization Window. Make your selections there and click “Confirm” to set the changes.

To make changes to the font style and boldness of text for the scalebars, and to font size for the on-image scalebar, see the "Select Font for On Image Text" topic page.

**********************************************************************

APPLICATIONS

This section deals with utilities which extend the functionality of your program.

Contents

Annotation Text Tool
Montaging
Database

**********************************************************************

AMT's Annotation Text Tool

On the left of the AMT display is the activator button for AMT’s Annotation Text Tool. A final image is needed in order to place text. After collecting one, click on the big "T" on the toolbar. This will open the "Mouse Directed Annotation" window. In the "Text Input" window enter your text. Place arrows and special characters using the buttons provided above the input window.
1. With the window still open, place the text by clicking on the image with the mouse.
2. Move the text by moving the mouse and then clicking again.
3. When the text is where you want it "Burn Text Into Image" by clicking that option in the Annotation window.
4. Saving the image now will save it with the text added.

Clicking "Proc/Meas" on the upper menu and then clicking "Undo Graphics" will remove ONE layer of added text. To change the style, boldness or size of the text that gets placed, see the topic "Select Font for On Image Text".

Montaging

AMT's montage package employs stage motion to scan an array of images. Thus it is capable of collecting low magnification montages. The program can be used with or without a motorized stage.

Contents

Collecting Images for a Montage
Collecting and Naming Conventions
Stitching With ImageJ or Fiji

Collecting Montages

Note: Having a dark image correction and a background correction are both important for montaging. You might get the best results if you take a fresh background at the mag of your montage's final images.

Note: The montage function is being revised in early 2016. The AutoStage option will no longer supported after version 7.00.80

1. Select the appropriate Montage Acquisition Mode from the Special Acquisitions menu. In the AutoStage option, the computer controls the stage motion and image collection automatically after setup. In the User Controlled option, the camera application guides the user through the montage process, but the user controls the stage. If the TEM provides stage control, both options
2. Provide a name for the folder where montage images will be saved. Design a name without spaces or commas.

3. When you click "Accept And Start" the montage control panel will appear.

The image will go “live.” You should now set up the parameters for acquisition.

Typically, overlap should be 20% for automatic stitching. Note also that mechanical stage drives have an inherent uncertainty or repeatability error associated with them. This variation depends on the
At higher magnification this uncertainty is a greater fraction of the image field of view. Generally higher magnifications will require larger overlaps to compensate for stage variations.

15+% cropping is needed for side mounted cameras to reduce "S" distortion of the projector lens. But 0% cropping should work for bottom mounted cameras. Set Final Image Bit Depth refers to the number of bits used to represent the intensity in a pixel. For all but very specialized purposes, set this to 8.

Choose the mode for setting the magnification. Select either final magnification OR the number of snaps (pictures) in the longer axis. The magnification or snap values are selected in the pull down menu immediately below the Parameter menu item. Be sure to click Set after choosing a number.

Backlash correction (Yes/No) and Dwell Time (the amount of time required for the stage to stop drifting after it has arrived at a programmed position.) need to be set for montages using Auto Stage motion. They don't matter for User Controlled collection.

After setting Parameters and Settings a mag number, click Use This Screen. The program will take an Overview image at the current mag, and then raise the scope mag (or tell you to raise it) for montage image collection. If the program does not automatically read the scope’s mag it will prompt the user to input mag info.

After mag has been increased the user is prompted to adjust the focus and beam intensity. The intensity as observed on the histogram should be approximately centered. If collection is User Controlled (not AutoStage), you will be prompted to make an initial adjustment in the sample position also. Locate a feature that will be in the center of the bottom right montage image, and move that to the center of the monitor, using stage control.

Click Start Collecting Montage. Status of the collection is displayed in the panel on the below that button.

AutoStage Mode:
The program automatically moves the specimen to the appropriate positions and records images. Status
messages will be displayed in the Montage Control Message window. When done a message box will announce that acquisition is complete. The images and an information file will be stored in the folder specified in Step 2.

**User Controlled Mode:**
This is a computer assisted mode of operation, which prompts the user to move the specimen and indicates when to record a picture. Instructions are displayed on the montage control panel. Use the stage rods to move a sample feature to an overlap area, where it will line up with the underlying image. (See step a below.)

![Montage Control Panel](image)

After recording the first image, the program will prompt you to move the image in a certain direction (left, right or down) and will freeze the expected overlap region. The overlap region is duplicated on one side of the live image. This region will display in partial transparency the image behind it. Move the image in the direction of the duplicate and line them up. For instance, if the instruction is to "Move Right", move the stage to the right until the area in the transparency is overlapped by the image. To turn the transparency on and off click CompareOff on the upper menu of the Montage Control window. When the moving image lines up with the section in the transparency it will take on a "mushy" look. Adjust position so the maximum mushiness is in the center section of the transparency. Clicking on the image will create a horizontal or vertical line, to help you guide a feature to its match in the semi-transparent region. You can move the line by more clicking.

When position is correct click on Continue. Then Step a) will repeat until finished. When done a message box will announce that acquisition is complete. The images and an information file will be stored in the folder specified in Step 2.

To stitch the images into a montage, see the topic "Stitching Images Using ImageJ or Fiji".

**Collection and Naming Conventions**
Normally the AMT Capture Engine will generate an Info.txt file for the images it collects from a montage area. In some cases, for example a large irregular region, the user may wish to create a custom project to assemble the images. The following discussion explains the order that images are collected and the naming convention used.
1. Montage images are collected in a serpentine path (boustrophedonic) starting at the bottom right corner of the image.

Image Collection Order

2. An image’s name gives the number of its row and its column in the montage as shown below.

R1C1.tif
R1C2.tif
R1C3.tif
R1C4.tif
R2C1.tif
R2C2.tif
R2C3.tif
R2C4.tif
R3C1.tif
R3C2.tif
R3C3.tif
R3C4.tif
R4C1.tif
R4C2.tif
R4C3.tif
R4C4.tif

The Info.txt file has parameter information which is automatically entered by the AMT ImageJ Toolbar stitching shortcut. If you access the ImageJ plugin parameter window directly Info.txt is not used.

3. The montage images, an overview image and the information file are stored in the folder created for the montage during the setup process.
Stitching Montages Using ImageJ or Fiji

AMT Toolbar Shortcut to ImageJ Stitching
The AMT add on toolbar for ImageJ contains a shortcut to send a montage to the appropriate ImageJ plugin for stitching. The rightmost icon on the toolbar is a needle. Click the needle, OK the dialog box and browse to the folder containing your montage. This initiates the stitching of your montage in the non-deprecated grid stitching plugin. After the montage is fused and displayed, save it as the resulting image.
Direct entry to ImageJ plugins
If you don't have the AMT toolbar for ImageJ, or if you would like to experiment with other stitching options and parameter values, you can access the plugins directly from the upper toolbar of ImageJ (some versions of which are called "Fiji"). ImageJ's stitching utilities are plugins, which drop down in a list when you click the **plugins** menu on ImageJ's toolbar.

The two plugin choices which AMT has tested with its montages are "Stitching -> Grid/Collection Stitching", and "Stitching -> Deprecated -> Stitch Grid of Images". The main reason deprecated grid stitching is offered as an alternative is that it allows you to set the "Fusion Method" to "None", which is not allowed in the latest grid stitching. If the scope has any S-distortion, and you do not crop much during montaging, the results may look better without fusing. Besides these two, you can also experiment with the other stitching plugins (AMT would appreciate hearing about your results).

**Stitching Order**
When you choose the non-deprecated Grid/Collection Stitching, the window that comes up presents a choice for the order in which the images will be stitched. From the drop down menu designated "Type" choose "Filename defined position". AMT montage collection uses this protocol in assigning filenames.

If you choose the deprecated grid stitching, filename positioning is already chosen, and you do not see this window,

**Parameter Window**

After the stitching order is set, the stitching parameter window will appear. The items here which you need to change are: "Grid size x" and "Grid size y" - the number of images in the x and y direction, "Directory" - Browse to the folder containing your montage, and "File names for tiles" - type in "R(y)C(x).tif". Note that x and y are each enclosed in upper case brackets, not parentheses. For other parameters in the window the default values are a good place to start, and they can be tweaked to suit your needs and tastes. If you want to stitch a subset of a large montage set the "Grid size" x and/or y to a smaller size. You can also use numbers greater than 1 for "First file index" x and/or y, to skip the first column(s) or row(s). For large montages be sure to conserve memory in "Computation parameters".
Close up in window.

**Memory Limit**
If your montage is pushing the limit of available memory even after saving memory in the parameter window, you may be prompted to increase the memory limit in ImageJ’s Edit -> Options.
Stitching Older Version AMT Montages With ImageJ plugins

Older versions of AMT saved montage images with longer file name. The names were tailored to a different stitching program. But these file names still contained the tile's row and column information, at the end of the pre-suffix string. In order to stitch these montages with the ImageJ plugins, use the procedure described above on this page, but in the "Names for tiles" window enter the string (iiii)R(y)C(x).tif

That is exactly the same as for modern montages, except there are five lower case i's, in upper case braces, as place holders (wildcards) for the five extra characters in the older filenames.

Database

AMT Database and Meta-data
AMT maintains a database of the meta-information associated with images that are acquired using the Capture Engine. This is information such as the magnification of the image, TEM mode, the accelerating voltage of the TEM, the microscopist, the time and date the image was acquired, scaling information, the laboratory name, as well as two user supplied caption lines and up to 6 keywords.

This information is stored in an rtf (Windows WordPad) file, the tiff header, and optionally into a logo band directly on the image.

Contents

AMT History .rtf File
Tiff Header

The AMTHistory RTF File

Metadata is written into the file C:\AMTHistory\AMTImagingDataBase1.rtf each time an image is saved. This is simply a text file which saves each field of information on the TEM Info Form that requests/displays the metadata just before an image is saved.
On systems with TEMs that support communication with external applications the Capture Engine is able to obtain much of the information automatically (Grey background). On TEMs that do not support communication the user will need to enter (if desired) the Magnification, accelerating voltage, TEM mode, xy position, and tilt. Some fields - caption lines and keywords always depend on user input (White Background).

Items that are checked on the information form will be written into the image caption band. However, all the information is written into the rtf database. This is simply a tab delimited table with the following fields:

- FileName
- Microscopist
- Date_And_Time
- TEM_Magnification
- CaptionLine1
- CaptionLine2
- Pixel_Calibration
- X_Position
- Y_Position
- Tilt
- Accel._Voltage(kV)
- TEM_Mode
- TEM_Facility
- Account
- KeyWord1
- Keyword2
- KeyWord3
- Keyword4
- KeyWord5
- Keyword6

If the field is empty, it is left blank in the rtf file.

**Importing the RTF into a Spread Sheet**

An rtf file can be opened by Windows word Pad and an atb delimited table can easily be imported into a spreadsheet program. As an example, to import into Microsoft Excel:

Select a cell where you want to place the data. Go to the Data Menu and select Import:
Confirm the information that the import wizard presents.

The table is tab delimited
Chose the data format for the spread sheet

Confirm the location you selected above.

Other spreadsheet programs are likely very similar.
Meta-data In the Tiff Header

The meta-data is also stored in the tiff header. Information from this location is used to scale images automatically when opening them in *ImageJ*. In addition, it may be possible in some image processors to display this information for examination.

![Current Image Information](image.png)

Corel Paintshop Pro Information Display

Some databases may also have the capability to extract this information for entry into database fields. Fields in this tag are delimited by a Carriage Return and occur in the following order:

- TEM_Facility
- Date
- Time
- TEM_Magnification
- Print Width
- Accel._Voltage(kV)
- TEM_Mode
- CaptionLine1
- CaptionLine2
- Keyword1
- Keyword2
- X_Position
- Y_Position
- Tilt
- Pixel_Calibration
- Pixel_Calibration - this is a duplicate and will be phased out in a future version
- Calibration Unit
- AMT tag format version marker
MAINTAINENCE

This section is intended for people that are qualified to work on the AMT software and hardware, including installing and servicing engineers.

Contents

Computers
Optical Hardware
TEM Communications
Computer Issues
This chapter discusses computer issues which are commonly handled by scope users or their I.T. Department personnel.

Contents
Maintenance Utilities
User Accounts
Networking
Ownership and Permissions in Windows 7

Maintenance Utilities
The TEM digital camera is a high speed data acquisition system that puts heavy real-time demands on its computer and generally produces many, very large files. Maintaining performance requires some routine maintenance procedures that are readily available in the Windows operating system. This sections describes some of the most basic operations that should be done monthly.

Checkdisk:
This is your most powerful tool for restoring efficiency. To turn Checkdisk on find the C drive in "My Computer" or "Windows Explorer", right click it and click "Properties". "Tools," where you will find "Error Checking". Click "Check now" and select the first cleanup option, "Automatically fix file system errors." Then the system will tell you to reboot your computer.

Note: If you select "Scan for and attempt recovery of bad sections" this operation will take a long time. This operation should be used only when you suspect a physical problem with the hard drive or you have a few hours to spend on the operation (i.e. overnight).

Safe Mode:
This utility is a barebones version of Windows, which is used for diagnostic and repair purposes. It also rewrites registries and repairs files during the boot process, so just opening in Safe Mode can sometimes fix a system. To get into Safe Mode "Restart" your computer. Before Windows starts, push and hold down the F8 key on your keyboard. This should produce a screen with several options including the SafeMode Start option. The startup takes a few minutes during which file names are displayed. After the startup your Desktop Icons will be enlarged since the graphics card is not running. When the computer is done starting up tell it to restart again, this time without pushing F8.

Defrag:
This can be done after Checkdisk and may not be needed every time. See how many files are fragmented when the Defrag display starts. The Defrag actuator is on the C drive's "Properties - Tools" tab along with "Error Checking". This is another time consuming procedure for lunch or overnight break.

Disk Cleanup:
If you do not browse the internet you probably will not have a lot of temporary internet files plugging things up. However, it still wouldn't hurt to do a cleanup occasionally, especially if you're on a network. To start the process, click "Start Programs/ Accessories/ System Tools/ Disk Cleanup". Select the C drive and check the categories that contain unneeded files.

User Computer Accounts
AMT computers are usually shipped with two accounts for use: "Administrator" and "User1". Both accounts have administrative privileges in Windows. If you create separate accounts for camera users, they will not be able to use AMT until the new user has full control of the folders listed below. The
folders' "Security" tab might not be available until, in Windows Explorer, to go to Tools->Folder Options and on the "View" tab, unclick "Use Simple File Sharing". Users need Full Control to the following folders (including sub folders): C:\AMTcommon C:\AMThistory C:\Images C:\ImgMeas C:\Montages

NOTE: A network drive, or other designation for saving images, must be write enabled also.

If your AMT software has these folders in the "All Users" folder, they should already be fully accessible.

Networking

For many labs, the AMT computer is used without networking. Each user downloads their images onto a CD or a flash drive. Ideally, even a non-networked computer should have an antivirus utility if there's a lot of users. That decision depends on what priority you place on the data stored on the computer. Any computer that does get networked needs an antivirus utility, unless it's on a super secure network.

Bare Bones Networking

For those AMT computers that do get networked, for file sharing and/or for Internet, there are a few precautions. First, AMT is most compatible with "Bare Bones Networking". This kind of network give the I.T. Department enough control so they can, for instance, upgrade the virusware and run Windows updates from a central location, but less options for remote control than is common in some labs. "Zen Masters" and similar utilities for complete remote control are ruled out. When networking is done there should still be only one Display Adapter visible in the computer's Device Manager (right click "My Computer" and choose "Properties", then "Hardware" and "Device Manager".

Frames Per Second

There is convenient way to at least partially monitor the effect of networking software. Before the process of creating a network begins, do a check on the frames per second (fps) at which your camera runs. This number is given at the lower right part of your AMT display, above the buttons for "Set/Save" and "Recall". Check what the rate is for Survey mode and Focus mode imaging, and make a record of it. When networking is finished the fps should be the same as before networking. If networking slows down AMT it will affect image quality. If that happens a lighter network protocol needs to be adopted.

Saving To A Network

If you plan to save images to a network drive, make sure the drive is write enabled. The account of any user that saves images must be set to have full access on the drive's "Properties -> Security" tab. If the Security tab isn't displayed deselected "Use Simple File Sharing" in Windows Explorer's "Tools - Folder Options -> View" tab.

“Ownership” and permissions for files access in Windows 7

Symptom: In Windows 7, file ownership and permissions related issues may occur when attempting to install DVCView or when manipulating installed files.

Solution: Windows 7 has implemented an additional security mechanism to prevent accidental or intentional file or folder modification. This is accomplished by not allowing users other than owner of file or folder to access it. Therefore, if you need to access, modify, or delete such files or folder you need to take ownership first, and then assign rights or permissions to respective users. This procedure will show how to take Ownership and Grant Permissions in Window 7.

How to take Ownership in Windows 7:  
1. Locate the file or folder on which you want to take ownership in Windows Explorer.  
2. Right click on the file or folder and select “Properties” from Menu.  
3. Click on Security tab.
4. Click on “Advanced” button.

6. Click on ‘Edit’ Button and select user. Note: if user or group is not in object name field, then click on ‘Advanced’ button.
7. Click on ‘Find Now’ Button and select user from the list, next Click OK.

8. Check the box ‘Replace owner on sub containers and objects’.

9. Click ‘OK’ when Windows Security Prompt is displayed.
10. Owner name should have changed. Next, Click OK to exit from the 'Properties' window.

Note: Once you have taken ownership of the file or folder, the next task is to Grant Permissions to that file/folder or object.

**How to Grant Permissions in Windows 7:**

1. Locate the file or folder on which you want to Grant Permissions for.
2. Right click on file or folder and select 'Properties' from the Menu, then select the 'security' tab.
3. Click on 'Edit' button.

4. Select user/group from permission windows or Click 'Add' button to add some other user or group
5. Next, under Permissions section check the rights which you want to grant; e.g. check 'Full Control' under the 'Allow' column to assign full access rights control permissions to Administrators group.
6. Click ‘OK’ for changes to take effect and Click ‘OK’ again to exit from Properties window.

Done - now you can access files or folders in Windows 7 with full permissions and take full control of the data within.
Optical Hardware

This section is intended mainly for engineers who install or service AMT systems.

Contents

Balance and Focus the Lens
Phosphor Maintenance

******************************************************************************
Balancing and Focusing the Camera Lens

The AMT camera and lens are focused on the AMT phosphor, permanently. This focus is set as part of the installation process and normally does not need adjustment after that. "Balance" refers to the relationship between the camera and its lens, such that all four corners are equally in focus. Setting the balance is different depending on whether the camera system is attached to the side or bottom of the column, whether the lens has a focus knob and how many mirrors are involved.

Contents

Sidemount Lens with a Focus Knob
Mirror Alignment (sidemount)
Bottom Mount with a Focus Knob and No Mirror

Balancing And Focusing The Camera Lens (sidemount)

AMT lenses have very high macro-optical performance with maximum sharpness and high numeric aperture. To achieve this, the lenses conform to a highly corrected, finite-conjugate design protocol with 12 or more elements per lens. Such designs have a very limited range of focus (~ 10 μm) and require precise alignment to maintain proper focus across all four corners of the image.

All AMT's lenses are focused and aligned on an optical bench before shipment. However, on the systems that have a focus knob, especially side mounts, check the balance during installation and adjust if necessary. Mechanical parts can shift during shipment and machining tolerances on mounting surfaces contribute to misalignment as well. It is also possible that the mirror block is not set perfectly square during installation. (To check mirror alignment see ("Squaring the Mirror"). If one or more of these factors occurs, the camera will be misaligned. In this condition the camera cannot be focused evenly across the entire field. So typically the image will appear blurring on one side of the field.

For checking balance and focus you need a sample with lots of detail. A waffle calibration grid is often good. Set the mag at about 30KX, although you can experiment with this.

Check The Balance

A utility to help you see if the corners are balanced is AMT's "Display For Alignment". On AMT’s upper menu click “Utilities->Camera and Optics Adjustment->Display for Alignment”. This utility brings the four corners of the image to the center for comparison. It also uses the less binning than Survey mode, and turns the background correction off.
If necessary, you can bump up the contrast in **Alignment Mode** by turning off the **Autogain** and moving the slider bars that are underneath the histogram.

To see if the four corners go through focus together take the lens through focus, by moving the focus knob back and forth. Bring the image into focus from one direction, then bring it in from the other direction.

Do all the corners come into focus together?  
When one side is in focus is the opposite side also exactly in focus?  
If you see a focus difference in the corners adjust balance by adjusting the cap screws (SHCS) which hold the camera and lens together, and the Set Screws, between the caps, which push the camera and lens apart.

**Mapping Screws to Corners.** The hard part, for beginners, is knowing which screw to adjust to focus a given corner of the image. The picture below maps the corners of the camera to the corners of the image.
Here are two more pictures to help you map the corners of the camera to the corners of the Alignment mode image. It looks at the image on the monitor with AMT in **Display For Alignment** mode, and at the camera from the back.

Corners 1 and 3 stay anchored, but 2 and 4 get flipped.

When balancing, you should draw yourself a diagram of what you are doing. The next question is which way to turn the screws. If the camera is on your left with the focus knob on top, then the following rules apply:

1. At the corner which requires you to "pull" the focus knob toward yourself, the camera and lens are too close together. Loosen the SHCS and tighten the Set Screw.
2. At the corner which requires you to "push" the focus knob away from yourself, the camera and lens are too far apart. Loosen the Set Screw and tighten the SHCS.
When you are finished balancing, the SHCS and Set Screws should all be snug, but they do not have to be as tight as flange mounting screws.

**Final Focus**
When the lens is in balance use focus knob to fine tune the focus, and tighten the knob to set it permanently. Use AMT’s "Focus" mode. Turn background corrections Off. In the image, look at the finest detail you can find and also look at the beam noise. The scope's mag should be between 20KX and 50KX.

**Sidemount Hardware Installation**

**Location And Orientation**

**Barring** special circumstances, sidemount cameras are placed on the left side of the column and the mirror/phosphor mechanics go on the right.

The flange that the camera mounts to is stamped on top, meaning "this side up". The focus knob of the lens is also on top. This picture shows the orientation of two families of cameras.

On the few scopes where the camera goes on the right because of obstructions, the orientation is rotated 180 degrees (focus knob on the bottom). The mirror's orientation on the rail does not change.

**Attaching The Mirror**

**Mirror Spacer**. Your kit includes a flat spacer which can be placed between the mirror and the rail to lift the mirror microscopically. If the limiting factor in the camera’s field of view is a straight vertical edge at the right side of the image, inserting a spacer will reduce that edge.
Squaring The Mirror.
Getting the mirror squarely mounted to the rail is very important for alignment. Use a straightedge or a gauge block to make sure that the mirror's rear surface is parallel to the mounting flats of retractor flange. Get the mirror mounted squarely before attaching pneumatic lines, and before attaching the phosphor holder. The mirror block is connected to the insertion rail with two socket head cap screws (SHCS). Next to these screws are two setscrews that act as alignment pivots.

Left-Right Alignment: Set up the retractor as shown below. Loosen the two SHCS slightly, and very gently make the back of the mirror block touch the straightedge evenly. Check this by gently going back and forth with the hand crank while checking the gap. All operations should use minimum force.
**Up-Down Alignment:**
Set up the retractor as shown below. Gently check that mirror block touches the straightedge evenly.

Getting the mirror both left-right square and up-down square may require checking each way multiple times and making small adjustments on each pass. When you are finished all the screws should be tight enough that the mirror will not easily be dislodged or twisted.

Having a two-inch gauge block to use for squaring, instead of a ruler, makes the job easier. They can be found online. A machine shop may make you a few, for less cost than the online ones.
GAUGE BOCK. THE LONG DIMENSION IS TWO INCHES.

ATTACHING THE PHOSPHOR

The phosphor holder is held onto the mirror with two Philips screws. When tightening them hold the holder securely so the torque does not twist the mirror on the rail.

Make sure the holder's set screws are retracted and then place the phosphor in the holder, glass side down. When the phosphor is in place tighten the set screws carefully so that there is a small but even amount of force on all four corners.

BLOW THINGS OFF. Gently blow off any dust. Using a can of compressed air or other gas, blow off the top of the phosphor and the front of the mirror surface. This requires caution. Hold the can at least eight inches away from the target. Pull the trigger part way, to get a low pressure stream of air. Blow the stream at your hand first to set the stream and make sure it's all gas, no liquid. During the cleaning spray, keep the can in the same orientation - don't turn or shake it.

INSERT INTO THE COLUMN.

For putting the assembly back on the column, make sure the mirror is retracted (camera out). Be sitting for the insertion and put your elbows on the table top. Make all movements slow. Pretend you are in a slow-motion ballet. Get the top screws started and partly tight before you let anything droop.

GOING THROUGH FOCUS

When the hardware and software is installed get a beam in the scope, spread it, and insert the camera. When you move the focus knob on your lens the image should go to and through focus. If it cannot
reach focus because you cannot push the focus knob far enough away (with the camera-lens on the left side of the column) then you probably need a spacer between the lens and the flange. If cannot pull the focus knob close enough, check the centering (put a feature at the center of the TEM viewing screen and see how far it is from the center of the AMT camera image).

**Attach Pneumatic Line To The Retractor**

To properly do the final focusing, you need the pneumatic line in place and under pressure. Turn the scope off and close down the air supply to patch the T into JEOL’s pneumatic input. You can probably cut the 6mm hose, right after the scope’s first regulator (before branching for the valves) to place the T in.

**Important**: The air supply to the retractor needs to be regulated. At about 14 inches from where it connects to the retractor, splice the needle valve into the pneumatic line. Its rate should be set so that it takes about 1.3 seconds for the camera to go in or out.

**Bottom mount with a focus knob and no mirror**

All AMT’s lenses are focused and aligned on an optical bench before shipment. With bottom mounts the phosphor holder and optical mounting surface are shipped as a unit, so it is very unlikely that the lens corners are out of balance. However, the focus knob still does have to be set, so use that opportunity to check the balance. If you confirm that the lens needs a balance adjustment start with small adjustments and recheck often.

**NOTE**: For focus adjustments, and especially balance adjustments, you need a clear, close view of the monitor. It is usually worth the effort to move the monitor close, possibly even putting it on the floor, for bottom mounts.

**Check The Balance**

A utility to help you see if the corners are balanced is AMT’s “Display For Alignment”. On AMT’s upper menu click “Utilities->Camera and Optics Adjustment->Display for Alignment”. This utility brings the four corners of the image to the center for comparison. It uses the less binning than **Survey** mode, and turns the background correction off, both to help in seeing focus.

If necessary, you can bump up the contrast in **Alignment Mode** by turning off the **Autogain** and moving the slider bars that are underneath the histogram.
To see if the four corners go through focus together take the lens through focus, by moving the focus knob back and forth. Bring the image into focus from one direction, then bring it in from the other direction.

Do all the corners come into focus together?
When one side is in focus is the opposite side also exactly in focus?
If you see a focus difference in the corners (opposite corners are in focus at differing positions of the focus knob) then an adjustment of the lens balance is needed. The first step to doing that is to understand how the corners are oriented.

**Corner Orientation**

When you view an image on your AMT monitor it has the same orientation as the image on the TEM viewing screen (looking through the viewing port). So the rear-right corner on the TEM screen corresponds to the upper-right corner of the monitor, etc. With no mirror, the analysis of the lenses’ action is very simple: it reverses everything. So the rear-right corner of the image in the TEM screen gets transposed to the front-left corner of the camera. Every corner at the TEM screen is sent to the opposite corner of the camera chip. After collection the software reverses the corners again, so the orientation is straight for the monitor.

So as you can see, any corner of the image on the monitor (in Survey Mode) corresponds to the opposite corner of the CCD. That is where you will adjust focus for that corner to achieve balance. Fortunately, "Display For Alignment" mode reverses the corners again, bringing them into the same orientation that they are in at the CCD.
Same corner orientation

So to change the focus of the upper right corner on the monitor in Alignment mode, you would adjust the screws at the rear-right corner of the camera.

Adjusting balancing screws

The next question is which way to turn the screws. If the focus knob is on your left as you view the lens, then the following rules apply:

1. At the corner which requires you to "pull" the focus knob toward yourself, the camera and lens are too close together. Loosen the SHCS (cap screws) and tighten the Set Screw.
2. At the corner which requires you to "push" the focus knob away from yourself, the camera and lens are too far apart. Loosen the Set Screw and tighten the SHCS.

When you are finished balancing, the SHCS and Set Screws should all be snug, but they do not have to be as tight as flange mounting screws.

Final Focus

When the lens is in balance use focus knob to fine tune the focus, and tighten the knob to set it permanently. Use AMT's "Focus" mode. Turn background corrections Off. In the image, look at the finest detail you can find and also look at the beam noise. The scope's mag should be between 20KX and 50KX.
Phosphor Maintenance

Occasionally the microscope's technician or user is called on to replace the phosphor for an AMT camera. It's a simple procedure but requires a little caution. This chapter describes the change procedure for side mount and bottom mount systems.

Contents
Phosphor Evaluation
Phosphor Types
Changing Sidemount Phosphors
Changing Bottommount Phosphors

Phosphor Evaluation

Phosphors may accumulate dust and occasionally it is possible to burn a phosphor by exposing it to a beam that is too intense for an extended period of time. If a dust particle is thin enough that the background correction is able to compensate for the lost intensity, then cleaning the phosphor can be delayed until an opportune time. Unfortunately, in some cases the dust particle is too thick or moves relative to the background image when charged by the beam or jarred by the motion of phosphor insertion. In these cases, the phosphor should be cleaned immediately.

When evaluating the state of a phosphor it is sometimes the case that a background corrected image confuses the issues. It may be helpful to turn off all corrections for this purpose. This can be done by selecting the menu item:

"Corrections/Diagnostic Tools/Suspend corrections and Zero Thresholds".

Phosphor Types

There are three main physical designs for phosphors used by AMT. For all three, in the scope, the aluminum side points up (towards the beam).

Film Type (IF)

One design is called Film Type. It has a shiny aluminum coating on the side facing the beam, and phosphorescent material on the bottom. Both sides are delicate and shouldn't be touched. The transport case protects both sides.
Round Glass Bottom (IB)

Another type is round with glass on the bottom and a dull aluminum finish on the side that points toward the beam. They can be placed, glass down, on a soft surface, or lifted by something soft on the glass side, but don’t touch the aluminum side.

Rectangular Glass Bottom

Like the round glass ones, these have a glass bottom that can be touched by something soft, and a delicate gray side facing the beam. They are transported in a curved bottom dish with the delicate side down. As with the other types, grab it by the edges.

Glass side up in dish. Aluminum side points toward beam.
Changing Sidemount Phosphors

Here are the three types of sidemount phosphors, each mounted in its respective holder for installation. They each have either the shiny aluminum side or the dull aluminum side up.

![Phosphors for Sidemount Cameras](image)

Procedure for Changing Round Phosphors

1. Vent the TEM camera (film) chamber only. Some old JEOL100/200C and Zeiss “orange column” microscopes need to vent the column as well. You never need to vent the gun.
2. Make sure the mirror is in the retracted (camera out) position. You may have to remove the pneumatic tube that powers the mechanics. Remove the 35 mm retracting flange from the TEM, using a hex wrench for the bolts. Side-mount systems normally install the retractor on the right [exceptions H7000/H7100 and some orange column Zeiss’s].

![Procedure for Changing Round Phosphors](image)
3. Remove the phosphor. After removing the assembly put the mirror in the extended (camera in) position for working on it. Loosen the four set screws (one at each corner) that hold the phosphor in the holder. In film phosphors there are small holes in the rim of the phosphor. The small hex wrench you used for the set screws will fit into the holes, allowing you to pry up the phosphor so you can grab it by the sides and move it to an empty holder. Glass phosphors can be pushed up from the bottom by something soft. Be careful to not have anything touch the mirror. After removing the phosphor, make sure the set screws are fully retracted so the new phosphor will drop into place.

![Hex Wrench](image)

![Holes in the Rim](image)

Film Type Phosphor

4. Mount the new phosphor. Grabbing it from the sides, lift the new phosphor into place. If it's a glass phosphor, you'll have to flip it after lifting out of the transport case to get the dull aluminum side up. The film ones are transported with aluminum up. After the phosphor is in place, tighten the corner set screws. They need some torque, but not much. If the phosphor is a film type, carefully check the top to make sure there's no buckling of the surface.

![Use small hex key](image)

Glass Type Phosphor

5. Gently blow off any dust. Using a can of compressed air or other gas, blow off the top of the phosphor and the front of the mirror surface. This requires caution. Hold the can at least eight inches away from the target. Pull the trigger part way, to get a low pressure stream of air. Blow the stream at your hand first to set the stream and make sure it's all gas, no liquid. During the cleaning spray, keep the can in the same orientation - don't turn or shake it.

6. For putting the assembly back on the column, make sure the mirror is retracted (camera out). Be sitting for the insertion and put your elbows on the table top.
Rectangular Phosphor Replacement

If you need to replace a rectangular (GA) type phosphor, it will probably arrive already fastened into a mounting bracket, with a flat cover held onto the top with small screws. You change the bracket using the two screws at the rear. Make sure the glass side is down when mounting. After the bracket is attached remove the cover. Be careful not to let the screws or the screwdriver touch the surface of the phosphor.

![Holes for mounting to mirror]

Changing Bottommount Hardware

Changing a bottom mount phosphor requires removing all the AMT hardware from underneath the column. The kick cover, camera and lens, and the lens mounting block can be removed without breaking vacuum. Remove the lens and camera together. Be sure not to tamper with the screws that hold the lens to the camera. The Flange to TEM contains the phosphor. It is fairly heavy, although it shouldn't require a floor jack. Use a rubber band to fasten something soft over the glass on the bottom of the Flange before you remove it.

![Procedure for Changing BottomMount Phosphors]

Procedure for Changing BottomMount Phosphors

The phosphor is in the flange to TEM. When you have the flange on a table carefully remove parts until
you get to the phosphor. Mark parts as to orientation and position for reassembly. Be careful not to drop screws onto the phosphor. Film type phosphors have holes in the rim which can be used for lifting. Glass phosphors can be lifted from the bottom by something soft. When you’re done with replacement the phosphor’s aluminum side, either dull aluminum or shiny aluminum, should be facing the beam.

When the phosphor is in place gently blow off any dust using a can of compressed air or other gas. This requires caution. Hold the can at least eight inches away from the target. Pull the trigger part way, to get a low pressure stream of air. Blow the stream at your hand first to set the stream and make sure it’s all gas, no liquid. During the cleaning spray, keep the can in the same orientation - don’t turn or shake it. Use the same procedure on the other hardware parts as you reinstall them.

**************************************************************

**TEM Communications**

“Communications” is where the scope's computer tells the AMT computer its mag and KV. This subchapter discusses preserving communications during upgrades and setting up communications for the first time.

Contents
AMT Side Configuration
HyperTerminal
Scope Side Configuration

**************************************************************

**Configuration of Camera Application**

**Basic Configuration**
These directions are for AMT camera’s that have their own separate computer. For Integrated systems, or systems where the scope and camera share a computer, contact AMT for directions. The first thing to do on the AMT side for communications is to make sure the correct ComPort is selected in the software. That assignment is made in the camera's configuration folder in the file "SerialTEMPort.txt". Once that is done select the communications protocol by clicking "Utilities -> Special Options -> TEM Communications" and select your microscope in the window that opens. Restart AMT to incorporate the change. If communications doesn't work at that point you can check the connection using "HyperTerminal" (See next page).
H7650
If communication is with an H7650 scope, another text file may need to be created and saved to the camera's configurations folder. The file is "TEMComSetup.txt" and it specifies the baud rate, parity, data bits and stop bits. It sets those parameters on the AMT side to match those used by the scope computer's comport. The text that usually appears in the file is "9600, N,8,1" including the quotation marks. On the scope's computer, look at the comport setup in the menu "Maintenance\TEM adjustment" to see what parameter numbers are being used.
For almost all of the H7650s and the H7600s, the correct choice for communications is the triplet "Hitachi External Control H-7500 H-7600 H-7650".

FEI Morgagni, 208 and CM
To communicate with FEI Morgagni's and 208s, the AMT computer uses another utility called "RS232Remote," which was developed by FEI for external communication. For CMs the extra utility is "Remote Control Driver". If your AMT upgrade is for one of these scopes, contact AMT to see if the communications utility needs to be upgraded.

HyperTerminal
Running the "HyperTerminal" accessory on both computers simultaneously allows you to check whether a connection is live, and find out which Comports are used. In Windows XP HyperTerminal is integrated as an accessory, but not in Windows 7. A free trial version of different version of HyperTerminal can be downloaded at http://www.hilgaewe.com/hyperterminal/ Other versions can also be found with an internet search.
Setting Up HyperTerminal
This test requires that no other program is trying to use the specified Comport to communicate, so turn off AMT and on the scope side, turn off the user interface to the scope. The path to open the Windows HyperTerminal program is "Start -> All Programs -> Accessories -> Communications -> HyperTerminal". For the downloaded versions it will be either an installed program or an executable file in a folder.
When the program opens it will ask about making HyperTerminal a default program, to which you can say "No". It will ask for a name for this connection. Anything works. Then you choose which comport to use. If it asks for an Area Code, just make one up. Click "OK" to continue. When the "Port Settings" tab comes up accept the default values ("2400", "8", "None", "1", and "Hardware"). Just make sure both computers are using the same values. Click "OK" to continue.

On the top menu of the HyperTerminal window, click "File -> Properties", and in the window that comes up choose the "Settings" tab. On that tab click the "ASCII Setup" button.
Check all the rows on the **ASCII Setup** page. Click “**OK**” to continue.

Now, if the computers are connected by the specified ports, text typed into one of the windows will show up in both.
Scope Side Configuration

Communications software on the scope's computer is usually turned on and configured by the scope engineer, and is not usually a user function. The two exceptions to that rule are described here.

**EXT 1 and EXT 0**
For some JEOL scopes communications are turned on and off by typing "EXT 1" [Enter] and "EXT 0" [Enter] (including the space) respectively, into the scope's input panel. The AMT computer may have been doing that for you, but if the sequence gets interrupted, say by a power outage, you will have to manually set it to zero. Whether it is done manually or by AMT you can see it being entered on the JEOL monitor.

**FEI Tecnai**
The Tecnai is the one scope where AMT regularly adds and does upgrades to a communication program on the scope's computer. If doing an upgrade of AMT, contact AMT to see if the scope's "ExtTecnai" program need to be upgraded also. As a diagnostic test, you can see if ExtTecnaiG2 is running by looking in that computer's "Task Manager". Open by pressing the keyboard's "Ctrl", "Alt" and "Delete" keys. ExtTecnaiG2 should be running whenever the computer is running.
AMT Support

This section has contact information for applications support and camera repair. Contents

Applications Help, Repair and Problem Solving

Applications Help, Repairs and Problem Solving

Please call at:

Advanced Microscopy Techniques
242 W. Cummings Park Woburn, MA 01801 USA

Or use our website: http://www.amtimaging.com for further information.

You can reach us in person at (978) 774-5550 or fax us at (978) 739-4313. Our e-mail address is: info@amtimaging.com